WordPress.org

Forums

Amazon S3 and Cloudfront
Amazon S3 and Cloudfront Not Uploading to Amazon (32 posts)

  1. jbridgesbbc
    Member
    Posted 1 year ago #

    I have WordPress 3.8 installed and Amazon Web Services installed as a plugin on my website.

    I upgraded the PHP version of the server to be compliant (that was the first challenge) and defined the Access Key ID as well.

    The challenge is that when I upload an image, through wordpress, it just doesn't get uploaded to Amazon. I had my web developer look at it and he thinks it may be just be that the plugin is not compliant with wordpress 3.8.

    Could you share if the plugin has been tested with 3.8? Or if there are additional steps I can take?

    Seems like a great concept, so really want to launch my store with it if possible.

    http://wordpress.org/plugins/amazon-s3-and-cloudfront/

  2. pburch
    Member
    Posted 1 year ago #

    I'm having the same problem. Could it be a 3.8 thing?

  3. zwise
    Member
    Posted 1 year ago #

    I'm having the same issue. I'm on 3.8 as well

  4. TraciBunkers
    Member
    Posted 1 year ago #

    I'm having the same issue. It did work for me, but I'm not sure if I had already updated to 3.8. I Just updated to 3.8.1 in case that would make a difference, but it didn't.

  5. TraciBunkers
    Member
    Posted 1 year ago #

    Has anyone figured out a solution to get it to work with WP 3.8?

  6. tomkerswill
    Member
    Posted 1 year ago #

    I'm having the same issue with all my sites --- haven't been able to get the latest version of the plugin to upload (or even to update the URL to S3). No apparent errors - it just doesn't seem to upload to S3...

  7. Rojo Reyes
    Member
    Posted 1 year ago #

    It works on WP 3.7.1 (single site localhost setup) but it's not uploading files in a live multisite setup using WP 3.8.1

    Must be a 3.8 related issue

  8. tomkerswill
    Member
    Posted 1 year ago #

    I think this must be broken, as I haven't been able to get it work and it looks like lots of other people are having the same issues.

    Does anyone have any workarounds? Are there any other plugins that do a similar thing which people have had success with?

  9. Brad Touesnard
    Member
    Plugin Author

    Posted 1 year ago #

    It's working fine with my site on 3.8.1, so it's not a WP core compatibility problem.

  10. tomkerswill
    Member
    Posted 1 year ago #

    Hi Brad,

    Thanks for responding! That's good news. Is there anything else that can be done to debug this?

    Perhaps it's related to something else -- for example, in my particular case I upgraded from an older version of the plugin, to the latest -and then upgraded the WP core.

    This is not working on any of my 3.8.1 sites, so I think that there must be something odd going on here!

    Do you need me to send anything that could help debug it further?

    I'll also try and set up a new WP site with no plugins installed and see if this works... Perhaps we can isolate it that way?

    Tom

  11. ssirag
    Member
    Posted 1 year ago #

    I'm creating a proof-of-concept site to test the viability of building the S3 CDN into all our WordPress sites. I set it up with the AWS credentials in the wp-config.php, and I had the same problem identified above. I removed the wp-config credentials and added them via the web form in the AWS plugin, and it worked.

    I used this page for config guidance (especially the IAM permissions policy)

    http://blog.celingest.com/en/2013/07/19/tutorial-creating-cdn-wordpress-cloudfront-s3/

  12. tomkerswill
    Member
    Posted 1 year ago #

    Hi

    Just confirming that I, too, have the keys entered in wp-config.php and the S3 plugin is not uploading the content. So maybe that is the issue?

    I use Amazon Opsworks to automatically deploy sites, so being able to have the keys entered in wp-config.php is quite important for me. Is anyone else able to verify that this is working only when entered into the web form?

    Thanks

    Tom

  13. jbridgesbbc
    Member
    Posted 1 year ago #

    @ssirag - That post you shared by Victor from blog.clingest.com did the trick!

    I thought since the plugin didn't require a setup of cloudfront that it would work, but that was not the case for me.

    The changes that I made to get it working are:

    1. Set up cloudfront distribution
    2. Use the form to input the keys and removed them from wp-config.php
    3. I set up new user with the custom policy that was defined in the article.

    Thanks Brad Touesnard for a cool plugin and for everyone sharing their ideas on how to get it working.

  14. TraciBunkers
    Member
    Posted 1 year ago #

    Hmm, it didn't work for me. When I first installed the plugin, it worked for a few images, then stopped. Not sure if I updated wordpress before or after I installed it, or after.

    I originally put my key info in my wordpress config file. I took it out, input it from the form and tried again, but that didn't make a difference for me.

  15. TraciBunkers
    Member
    Posted 1 year ago #

    I just checked my error log, and it said:
    Error uploading /home/USERNAME/public_html/blog/wp-content/uploads/2014/02/amdad.jpg to S3: [curl] 6: Couldn't resolve host 'BUCKET-NAME.s3.amazonaws.com' [url] https://BUCKET-NAME.s3.amazonaws.com/blog/wp-content/uploads/2014/02/amdad.jpg

  16. TraciBunkers
    Member
    Posted 1 year ago #

    I got it to work!
    * I had already moved my access key info from my config file to the form.
    * I had a bucket policy that I deleted, and I put the same permissions for my IAM user as the link give by ssirag.
    * I deactivated all of my plugins except these two--and it still didn't work.
    * So I looked in my database and found a few orphaned options from a plugin I had installed about a month ago, and then deleted.

    It worked! So not sure if deleting those database options did the trick, or if it was a combination of everything.

    Then I decided to test to see if I could move my access key info back to my config file--it didn't work. I deleted it and put it back in through the form, and it worked again.

  17. MuchmoreGaming
    Member
    Posted 1 year ago #

    It's not uploading for me either. I've been through all of these steps...

    I've worked with Amazon S3/Clooudfront before and it's always been solid - for whatever reason with WordPress it seems to be next to impossible.

    Any help or feedback on this would be helpful. I've been through every step - the new AWS user, the new security policy, removing from config and adding to web form, deactivating other plugins, etc.

    No go.

    Anyone have any ideas?

  18. TraciBunkers
    Member
    Posted 1 year ago #

    MuchmoreGaming: In your permissions policy for your IAM user, be sure you put in the name of your S3 bucket. In the one given in the tutorial link, there are 2 places where it says "celingest-cdn", which is the name of the bucket in the example--put your bucket name in there. That might seem obvious, but at first I didn't even see those. I just copied & pasted.

    If you know how to do it, you might go through and see if there are any orphaned tables in your database that are causing it. I think that's what my problem was. I had installed the S2Member, then deleted it. It left some options tables in the database. It was after I deleted those that it started working for me again.

    And in the S3 and Cloudfront settings page, be sure where it says domain name, you've got your cloudfront name (XXXX.cloudfront.net) or cname. At first I just saw "domain name" and put my actual domain name in instead of my cloudfront domain name.

  19. mimosalguero
    Member
    Posted 1 year ago #

    Hi any news about this error message

    "Error retrieving a list of your S3 buckets from AWS: The difference between the request time and the current time is too large."

    I had changed my computer clock but it doesnt work either.

    thank

  20. TraciBunkers
    Member
    Posted 1 year ago #

    well, it's not working again for me. I just checked my log, and I have the same error as before. I don't get it. I haven't added any plugins.

  21. disturbedrod
    Member
    Posted 1 year ago #

    I'm having the same issues. "Error retrieving a list of your S3 buckets" I had to remove the plugin since it was making it impossible to work in my site.

    Also, I was getting an http error almost every time I tried to upload any media, at the beginning I was blaming it to wordpress, but since I removed the plugin the errors are gone

  22. esmi
    Forum Moderator
    Posted 1 year ago #

    If you require assistance then, as per the Forum Welcome, please post your own topic.

    This month old topic references an old version of WordPress.

  23. TraciBunkers
    Member
    Posted 1 year ago #

    I am still trying to resolve this and I've done everything I can think of to troubleshoot. The odd thing is, it'll transfer an image occasionally, and I can try again right after an image is successfully transferred, and it won't. Sometimes if I deactivate both plugins and reactivate them, it'll work once, but then not if I try uploading another image. I've tried with plugins off, and it doesn't matter. I've set up a test blog with a new database, fresh wordpress install and no plugins except these two active, and it won't upload. My amazon credentials are correct.

    I always have the same error in my error log: [curl] 6: Couldn't resolve host.

    Does anyone have other ideas of what the problem might be or what I should try? I've googled my error message, but can't really find anything helpful.

  24. esmi
    Forum Moderator
    Posted 1 year ago #

    @TraciBunkers: Please post your own topic.

  25. TraciBunkers
    Member
    Posted 1 year ago #

    esmi--I've been participating in this topic since it was first posted . . . so I'm confused why I can't continue posting in it since I'm still trying to resolve it. It seems starting a new topic with the exact same information would clog up the forum?

  26. esmi
    Forum Moderator
    Posted 1 year ago #

    These forums have guidelines. Please read them. As you will see, one of these guidelines - entitled Where to Post - specifically states:

    Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else's thread. Start your own topic.

    Please abide by this.

  27. TraciBunkers
    Member
    Posted 1 year ago #

    Okay, sorry. Several of us were having the same problem and we had the same version of WP, but I doubt we had the same plugins, themes, or were on the same server with the same web host. It seems that could cause a lot of threads to be posted with the same issue/questions, but I'm happy to follow the rules. I'll start my own topic, and copy & paste my info into it.

  28. esmi
    Forum Moderator
    Posted 1 year ago #

    Thank you. :-)

  29. TraciBunkers
    Member
    Posted 1 year ago #

    It's a little confusing because in the area to start a new topic, it says "Before posting a new topic, be sure to search to see if one has been started already."

    So that makes it sound like you shouldn't start a new one if there's already one going with the same issue/question.

  30. esmi
    Forum Moderator
    Posted 1 year ago #

    It means "See if you can find a solution in an existing topic" rather than "Post in an existing topic". But - yes - I appreciate that it is ambiguous. Unfortunately, that's not a piece of text that we can change easily. :-(

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Amazon S3 and Cloudfront
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic