Support » Plugin: Amazon Product in a Post Plugin » Amazon Product Advertising API 5.0

  • Resolved Ivan

    (@calvin13)


    Hello,

    Is the plugin compatible with the Product Advertising API 5.0?

    PA-API 5.0

    Thank you very much.

    • This topic was modified 2 years, 9 months ago by Ivan.
Viewing 15 replies - 31 through 45 (of 46 total)
  • Thank you!

    The big problem I have is that every book I show has Kindle Edition as the title of the book. It’s not showing the actual title even though I’m using ‘title’ in the shortcode.

    Hi @kokopoko22,
    This is a bug we are aware of. We already have a fix ready to go for it and I will push the update tomorrow morning.

    For anyone else reading, there was also a bug where the links were using the Add to cart URL when not checked (instead of the regular Detail Page URL). That will also be in the fix.

    I will also have a little more documentation/help in there, too.

    Warm regards,
    Don

    Unfortunately, I can’t get it to work at all, although I created new API keys and I am on the same website where the old version worked.

    [amazonproducts asin=”B008FYVI8Q”]
    doesn’t output anything

    [amazon-element asin=”B008FYVI8Q” fields=”title”]
    outputs only the div wrapper: <div class=”appip-block-wrapper”></div>

    Also if I switch back to the old version with the new API keys, it still works again.

    @mattmatt88,
    Can you tell me the locale you are using (i.e., amazon.com, amazon.co.uk, etc). When I try that ASIN in the US version it comes back with this response:

    The ItemId B008FYVI8Q is not accessible through the Product Advertising API.

    That could be because it is a product from a different locale, though.

    Also, I am not sure how much longer the old version will work because that is using the 4.0 API, so it may just be the cached items are still there or they haven’t shut it “off” yet.

    Regards,
    Don

    I used the DE version.

    Yeah, I am also wondering why it still works with 4.0.

    @mattmatt88
    if you can send me a copy of the error logs, that would be great. You can send to apipp@fischercreativemedia.com. I need to see what the actual fatal error was to be able to replicate it.

    Thanks!
    Don

    Hi ALL –
    I just pushed a new update a moment ago (version 5.0.1).

    This fixes a few minor bugs:

    • Fixed “Features” parameter from displaying “Array”. (3/10/2020)
    • Changed so ‘gallery’ field can also use ‘imagesets’ as it is supposed to. (3/10/2020)
    • Fixed title not displaying correctly when “hide binding” option off in settings. (3/10/2020)

    This does not fix the Fatal Error some of the users are experiencing. We are still working on finding the problem there.

    Regards,
    Don

    • This reply was modified 2 years, 3 months ago by Don Fischer. Reason: spelling

    Buenas tardes, Que Plugin tengo que descargar en mi administrador WordPress ya que no he podido configurar el API 5.0 de amazon. Si me pudieran ayudar. Tengo el ID de acceso y la clave secreta pero no he podido. Aclaro no soy desarrollador soy administrador de la pagina pero cuando estaba el API 4 lo puede hacer y me funcionaba.

    Saludos yt agradecidos de antemano.

    Salvador Nuñez

    @salvador3852
    You need the latest version of the plugin 5.0.6.
    To get the plugin to work with the New Amazon 5.0 API, you have to migrate your API Keys in the Amazon Affiliate portal. Once you migrate the keys, they will be able to use the 5.0 API. Just add those new keys to the plugin settings (Amazon will create new keys when you migrate).

    After you add the keys to your plugin settings and save the settings, you should be able to test the plugin to see if it is working. If it works, you should be good. If not, send us a Debug email for the plugin settings and we will look into it further.

    Warm regards,
    Don

    @ salvador3852
    Necesita la última versión del complemento 5.0.6.
    Para que el complemento funcione con la nueva API de Amazon 5.0, debe migrar sus claves de API en el portal de afiliados de Amazon. Una vez que migre las claves, podrán usar la API 5.0. Simplemente agregue esas nuevas claves a la configuración del complemento (Amazon creará nuevas claves cuando migre).

    Después de agregar las claves a la configuración de su complemento y guardar la configuración, debería poder probar el complemento para ver si funciona. Si funciona, deberías ser bueno. Si no, envíenos un correo electrónico de depuración para la configuración del complemento y lo analizaremos más a fondo.

    Un cordial saludo,
    Don

    Mi pregunta, cual Plugin debo añadir nuevo. Porque lo hice con el Plugin que tenia pero no me funcionó. Cual Plugin debo bajar.

    ventainternacionalonline@gmail.com este es el correo para la depuración

    @salvador3852
    If you had the Amazon Product in a Post plugin installed before and it was working (with the old API), then you can still use the same plugin. Just update it to the new one (version 5.0.6) and then Migrate your keys on Amazon and add the new keys to the plugin settings.

    There is no way to go back to using the Old Amazon PA API (which was 4.0) as they have discontinued it so using the old version of the plugin will not work.

    So, basically, you need to update the plugin, migrate your keys, add the new keys to the plugin and then you should be good to go.

    Don

    Si ya tenía instalado el producto Amazon en un complemento Post y estaba funcionando (con la API anterior), aún puede usar el mismo complemento. Simplemente actualícelo a la nueva (versión 5.0.6) y luego migre sus claves en Amazon y agregue las nuevas claves a la configuración del complemento.

    No hay forma de volver a usar la antigua API de Amazon PA (que era 4.0) ya que la han descontinuado, por lo que usar la versión anterior del complemento no funcionará.

    Entonces, básicamente, debe actualizar el complemento, migrar sus claves, agregar las nuevas claves al complemento y entonces debería estar listo para comenzar.

    Don

    Don Fischer. Disculpe, pero que Plugin debo usar, porque el que estaba usando lo borre y no me acuerdo cuál fue el que estaba utilizando. Cual es el que me puede funcionar… Necesito saber con cuál Plugin que tenga WordPress para Amazon puedo configurarlo y me va a funcionar. Y disculpe nuevamente. Por favor

    @salvador3852
    Ok – I understand now. I think there was a miscommunication – probably from the language differences.

    Our plugin is called “Amazon Product In a Post”. It is just one of many different plugins out there that use the Amazon Product Advertising API to get product information. The plugin you use to get products from Amazon will depend on how you want your product data displayed. I have no idea what you were using previously, so ours may or may not work. You will have to try it and see.

    Here is a link to the plugin page:
    https://wordpress.org/plugins/amazon-product-in-a-post-plugin/
    Or search “Amazon Product in a Post” from your plugin screen to install it directly from WordPress in your admin.

    Other plugins can be found if you search “Amazon” in the plugin list. I can’t tell you what ones work, what ones are good or what ones will be the best for you – because that is something you will have to research and figure out for yourself. Plus, I can only help you if you have problems with our Amazon Product in a Post plugin – not any other plugins.

    If you still need help after that, you will have to find a Web Developer or someone to help you figure out what you need.

    Warm regards,
    Don

    ——————

    OK entiendo ahora. Creo que hubo una falta de comunicación, probablemente por las diferencias de idioma.

    Nuestro complemento se llama “Amazon Product In a Post”. Es solo uno de los muchos complementos diferentes que utilizan la API de publicidad de productos de Amazon para obtener información del producto. El complemento que use para obtener productos de Amazon dependerá de cómo desee que se muestren los datos de su producto. No tengo idea de lo que estaba usando anteriormente, por lo que el nuestro puede o no funcionar. Tendrás que probarlo y ver.

    Aquí hay un enlace a la página del complemento:
    https://wordpress.org/plugins/amazon-product-in-a-post-plugin/

    O busque “Amazon Product In a Post” desde la pantalla de su complemento para instalarlo directamente desde WordPress en su administrador.

    Se pueden encontrar otros complementos si busca “Amazon” en la lista de complementos. No puedo decirte cuáles funcionan, cuáles son buenas o cuáles serán las mejores para ti, porque eso es algo que tendrás que investigar y resolver por ti mismo. Además, solo puedo ayudarlo si tiene problemas con nuestro producto Amazon en un complemento Post, no con otros complementos.

    Si aún necesita ayuda después de eso, tendrá que encontrar un desarrollador web o alguien que lo ayude a descubrir lo que necesita.

    Don

Viewing 15 replies - 31 through 45 (of 46 total)
  • The topic ‘Amazon Product Advertising API 5.0’ is closed to new replies.