Support » Plugin: Amazon Associates Link Builder » Amazon plugin and WordPress 5.0 (Gutenberg)

  • Resolved chiccodimaria

    (@chiccodimaria)


    Hi, Amazon Associates Link Builder is not available on block editor (Gutenberg) and WordPresso 5.0. Will some updates be available? Or is there some way to solve the problem. Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • Old editor is available as a plugin. Here’s the link: https://fr.wordpress.org/plugins/classic-editor/

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Hi @chiccodimaria,

    Currently Amazon Associates Link Builder plugin is not supported on Gutenberg editor of WordPress.
    Work in progress for to make it compatible with Gutenberg editor.

    Although as suggested by @samy002, It is working on classic editor of wordpress.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Resolving it for now as we’re aware of the requests.
    We will include in official plugin notes when Gutenberg support is released.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @chiccodimaria,

    We released v1.9.0 of the plugin today and would appreciate your feedback on this change. The release includes:

    • Added Product Advertising API (PA-API) response caching feature. This feature will prevent PA-API throttle by caching PA-API response and updating the cache asynchronously.
    • Added support for Gutenberg editor. We have been working hard to restore the AALB plugin functionality since the launch of Gutenberg editor by WordPress.

    Important Notes :

    If you use any of the default templates provided by the plugin in the Gutenberg editor, they will continue to work just fine. Further, all custom templates (with the sole exception of custom templates extended from the ProductCarousel template) will also continue to work fine. Due to a technical challenge introduced by the Gutenberg editor, any custom template you created by extending the ProductCarousel template will not work unless you make the following change.

    Here’s what you need to do to ensure any custom templates extended from the ProductCarousel continue to work in the Gutenberg editor.

    1. Update the plugin to version 1.9.0
    2. Look within the code for the custom ProductCarousel template to find the jQuery script which is located at the bottom of the template code and replace it with the following code snippet.

    *!
     * jCarouselLite - v1.1 - 2014-09-28
     * http://www.gmarwaha.com/jquery/jcarousellite/
     * Copyright (c) 2014 Ganeshji Marwaha
     * Licensed MIT (https://github.com/ganeshmax/jcarousellite/blob/master/LICENSE)
    */
    
    !function(a){a.jCarouselLite={version:"1.1"},a.fn.jCarouselLite=function(b){return b=a.extend({},a.fn.jCarouselLite.options,b||{}),this.each(function(){function c(a){return n||(clearTimeout(A),z=a,b.beforeStart&&b.beforeStart.call(this,i()),b.circular?j(a):k(a),m({start:function(){n=!0},done:function(){b.afterEnd&&b.afterEnd.call(this,i()),b.auto&&h(),n=!1}}),b.circular||l()),!1}function d(){if(n=!1,o=b.vertical?"top":"left",p=b.vertical?"height":"width",q=B.find(">ul"),r=q.find(">li"),x=r.size(),w=lt(x,b.visible)?x:b.visible,b.circular){var c=r.slice(x-w).clone(),d=r.slice(0,w).clone();q.prepend(c).append(d),b.start+=w}s=a("li",q),y=s.size(),z=b.start}function e(){B.css("visibility","visible"),s.css({overflow:"hidden","float":b.vertical?"none":"left"}),q.css({margin:"0",padding:"0",position:"relative","list-style":"none","z-index":"1"}),B.css({overflow:"hidden",position:"relative","z-index":"2",left:"0px"}),!b.circular&&b.btnPrev&&0==b.start&&a(b.btnPrev).addClass("disabled")}function f(){t=b.vertical?s.outerHeight(!0):s.outerWidth(!0),u=t*y,v=t*w,s.css({width:s.width(),height:s.height()}),q.css(p,u+"px").css(o,-(z*t)),B.css(p,v+"px")}function g(){b.btnPrev&&a(b.btnPrev).click(function(){return c(z-b.scroll)}),b.btnNext&&a(b.btnNext).click(function(){return c(z+b.scroll)}),b.btnGo&&a.each(b.btnGo,function(d,e){a(e).click(function(){return c(b.circular?w+d:d)})}),b.mouseWheel&&B.mousewheel&&B.mousewheel(function(a,d){return c(d>0?z-b.scroll:z+b.scroll)}),b.auto&&h()}function h(){A=setTimeout(function(){c(z+b.scroll)},b.auto)} function lt(a,b){return a<b;} function gt(a, b) { return a>b;} function i(){return s.slice(z).slice(0,w)}function j(a){var c;a<=b.start-w-1?(c=a+x+b.scroll,q.css(o,-(c*t)+"px"),z=c-b.scroll):a>=y-w+1&&(c=a-x-b.scroll,q.css(o,-(c*t)+"px"),z=c+b.scroll)}function k(a){0>a?z=0:a>y-w&&(z=y-w)}function l(){a(b.btnPrev+","+b.btnNext).removeClass("disabled"),a(z-lt(b.scroll,0)&&b.btnPrev||z+gt(b.scroll, y)-w&&b.btnNext||[]).addClass("disabled")}function m(c){n=!0,q.animate("left"==o?{left:-(z*t)}:{top:-(z*t)},a.extend({duration:b.speed,easing:b.easing},c))}var n,o,p,q,r,s,t,u,v,w,x,y,z,A,B=a(this);d(),e(),f(),g()})},a.fn.jCarouselLite.options={btnPrev:null,btnNext:null,btnGo:null,mouseWheel:!1,auto:null,speed:200,easing:null,vertical:!1,circular:!0,visible:3,start:0,scroll:1,beforeStart:null,afterEnd:null}}(jQuery);

    If you face any issues with this upgrade of the plugin please do post on the forum and share your experience, we hope you find these updates useful.

    @amazonlinkbuilder

    The plugin doesn’t work. I selected the amazon block, I wrote the product, but if I hit the “search” button nothing happens. How can I find jQuery to replace your code? Because I tried to look for it but I could not find it. Thanks

    • This reply was modified 9 months, 3 weeks ago by chiccodimaria.
    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @chiccodimaria,

    Some of the editor script might be getting blocked by adblockers, Please try to search by disabling adblockers on the edit page.

    Please share browser console log if this issue still not get solve by disabling adblocker on gutenberg editor page.

    Steps to get the console logs:

    Open the Console window in Chrome using Ctrl + Shift + J (or Cmd + Opt + J on Mac) Follow this for reference.
    Hit the Save button and check the console log errors
    Send us the screenshot of console log as it is by sharing them using any 3rd party image sharing tool.

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Regarding the jQuery script,

    That is for the case if you have created custom templates from Carousel template.

    If you are using only the default templates or not using any custom template then it won’t affect.

    @amazonlinkbuilder

    I don’t have ADBlock active on that page, I’ve also deactivated it completely but nothing, it does not work.

    This is my console log error when I hit the search button: https://ibb.co/TtXSQNT

    Plugin Author Amazon Associates Link Builder

    (@amazonlinkbuilder)

    Dear @chiccodimaria,

    Please share following details to help us debug the issue :

    1. Browser version on which you are facing the issue.
    2. Does the issue occur on all browsers or only a specific browser?
    3. PHP version (You can use plugins like display PHP version that display your PHP version on the WordPress dashboard)
    4. WordPress version
    5. PHP error logs (if any)
    6. List of plugins installed on your system
    7. Operating system

    Hi @amazonlinkbuilder

    1) Google Chrome 72.0.3626.81
    2) I tried now with Internet Explorer and the plugin works.
    3) Running PHP version: 7.1.26
    4) WordPress version 5.0.3
    5) No error
    6) Ad Blocker Notify Lite, Amazon Associates Link Builder, Classic Editor, Comments Widget Plus, Custom Twitter Feeds, Display PHP Version, Disquis Contional Load, Disqus for WordPress, Instagram Feed, Ivory Search, Jetpack by WordPress.com, Page Builder by SiteOrigin, Regenerate Thumbnails, SG Optimizer, Social media and Share Icons, Typekit Fonts for WordPress, Visualizer: Tables and Charts Manager for WordPress (Lite) and WP Product Review Lite.
    7) Windows 10

    Thank You for the help

    Running WordPress Version 5.1.1 and when I activate the Amazon Associates Link Builder plugin I get font encoding issues. Strange characters appear in all the postings where characters like apostrophes and such should be. When I deactivate the plugin these issues disappear. I also use the plugin classic-editor.
    Any solutions other than to stop using the plugin?
    Thanks

    eranbeard

    (@eranbeard)

    Same her – can’t use with Gutenberg- really need a fix ASAP as can’t create links

    If use Gutemberg as editor I can add just one product with Amazon Associates Link Builder

    credible0

    (@credible0)

    Thank you! for providing a quite triumph concept and knowledge with such an expertise information through which mine problem was sorted out.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.