The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

W3 Total Cache
Amazon Cloudfront Not Pulling (4 posts)

  1. mmergola
    Posted 3 years ago #

    Done a bunch of searches but nothing seems really resolved and not specific to my need, so let me try fresh.

    Using Amazon Cloudfront (currently not using a CName since I can't get past the main part) - Distributions: origin is my domain, domain name is alphanumeric.mydomain.com, status deployed
    W3 Total Cache - Enable CDN, Amazon Cloudfront (origin pull), on the CDN settings, everything is filled out properly, evident by "Test Passed" when I try.

    Now, if I check off anything to "host" on the CDN and save settings, the entire site goes nuts. It looks like nothing is actually pulled to Amazon. If I click through my site and go to an image, it shows it is hosted at alphanumeric.mydomain.com, however, it is blank. The formatting is all wacky (so I think the CSS isn't hosted either).

    Bottom line, using this setup, I don't think anything is actually being "pulled". What am I doing wrong? I don't want to use push since I update frequently.

    Any help is appreciated!


  2. Frederick Townes
    Plugin Author

    Posted 3 years ago #

    Did you create the distribution using W3TC?

  3. warakia
    Posted 3 years ago #

    Hi, I am having a very similar problem, just checked my site after a perfectly functioning distribution being in place for years and it has suddenly stopped working.

    When the CDN is disabled the site returns to normality instantly.

    I have tried the usual steps of updating codes etc, but I still have no success. Oddly the plugin says "Test Passed" when I try to test the distribution.

    Alarmingly I have tried checking direct links to individual previously uploaded images files and they display only 20% of the time. For the record my distribution was created through Amazon and has been in place for years.

  4. warakia
    Posted 3 years ago #

    Apologies, in my case I have isolated the problem to an issue with Amazon. Sorry to interrupt this thread, I would just say that don't assume that the AWS Cloudfront is flawless, it is well worth checking that thoroughly before you assume it is a W3TC issue.

    Thanks for all your hard work Frederick.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • W3 Total Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic