Support » Plugins » amazon aStore as a page

  • I just integrated the new aStore from Amazon into my blog.

    I did not use any plug-ins for this. Just created a new page template with no left or right siderbar to make some space for the store.

    The only down side it is not very customizable. You can only play around with the colors. (it is still in beta)

    Check it out: gps store

    Let me know what you guys think.

Viewing 15 replies - 1 through 15 (of 27 total)
  • cool! did you use an iframe to do that? i’m trying to do pretty much the exact same thing, but my store page goes boom. lol

    Wow. That’s pretty impressive. I haven’t even looked at the aStore email they sent me a while back; guess I’ll have to take a look after all!

    navigadget–can you tell us how you did this (both at astore and on your website). I am trying to do the same thing (with the shopping cart like you have). Thanks for any help

    I’m glad you guys liked it.

    Here is how I did it:

    1. Create a page template without the sidebars.
    2. Write a page with the template you just created.
    3. Paste the code Amazon gave you into this page.

    I’d be happy to give further details if anyone needs them.

    Humm, i have written the page template and when i go in to write a page and assign the template i just made, it does not show up under “parent page”.

    It won’t be in “parent page” – it’ll be in page template. Assuming you included the template header info.

    I did include the header info.
    Humm, well, in “write”->”page”, i do not have “page template”. I only have “discussion”, “password-protect”, “page parent”, “post slug”, “post author” and “page order”. am i looking in the right place?

    i did the same but using iframes .

    Boxing Store

    here is the code :

    <iframe src="http://astore.amazon.com/httpwwwthaibo-20/104-2713405-9541512" marginwidth="0" marginheight="0" border="0" width="650" height="1000" frameborder="0" style="border:none;" scrolling="no"></iframe>

    you just need to change the src for yours … except if u want to sell stuff for me :p

    And yes just make a new page template … and add the code ..

    You need to put the page template stuff at the very top of the new template, or you won’t see it under the template section.

    Looks like this:

    <?php
    /*
    Template Name: Commentless
    */
    ?>

    Replace the word “Commentless” with whatever you named your template, upload it, you should then see a Page Template section, with a dropdown, and your new template should be there.

    that’s weird. you don’t have the pull-down menu like this?

    i finally got it to work, though it took a good deal of fiddling around with things!

    my site
    store page

    everyone else may already know this, but as it was my first time to create a custom template, be sure that the page template includes this code at the top, or else it will not show up in your list of page templates to choose from:

    <?php
    /*
    Template Name: Snarfer
    */
    ?>

    (change Snarfer to the name of your template file)

    Well, you never have a dropdown if you have only the one default template.

    whoops sorry for the double-duty on the code there. i was too slow. 🙂

    @vkaryl-I don’t have a template page section in WP 2.0.4 admin area. I DID include this:
    <?php
    /*
    Template Name: Store
    */
    ?>
    but it does no good because i don’t have a template area.
    @moodydesign-Nope, i don’t have that. You have 7 sections in write->page and i had 6. Yep, “page template” is not there. I can give you login info, if you would like to see.

    carnold: does your theme include an archives.php file? Or a links.php file?

    If not, then apparently the only template you can select will be the one you set up – that is, Store. If you have only one file with the template header info, then you won’t see a dropdown.

    it sounds like the page template option isn’t showing up beecause only your theme’s default template is available for choosing… in which case, the page template you uploaded isn’t in the right directory.

    make sure you put it into your theme directory and not the wp install directory.

    for example, mine is in:
    my url/wp-content/themes/mytheme/

    if you uploaded your template.php file (or whatever you named it) into the theme directory, you should be able to see the page template drop-down on the write>page page… also you should be able to see it in the list on the right of the presentation>theme editor page.

    i hope this helps! 🙂

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘amazon aStore as a page’ is closed to new replies.