Support » Theme: Chosen » Amazing theme!

  • Was looking for a new them for my personal travel blog. Something with a bit more space but clean, with nice big pictures. Chosen (what’s in a name) is just perfect, I love it!

    Only thing that’s too bad is when there’s an update, you have to redo the personalisation changes (changing content from English to Dutch for instance and adding my copright in the footer).

    • This topic was modified 1 year, 5 months ago by  boon64.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Theme Author Ben Sibley

    (@bensibley)

    Thanks so much for the review!

    If you translate Chosen to another language and send me the translation files, I can include them in the next update so you don’t have to repeat the translation. Here’s a tutorial you can follow to translate the theme: https://www.competethemes.com/help/translate-chosen/

    I also want to let you know that you can create a “child theme” for Chosen and make your changes to the footer.php file there. We have a starter child theme for Chosen and setup instructions available here: https://www.competethemes.com/help/child-theme-chosen/

    Hi Ben,

    Thanks for the tip! I did as you said and now everything is nicely translated again. At first it didn’t work but then I selected ‘Deutsch’ in the settings. Refreshed the site (saw it in German), then changed the settings to Dutch again and refreshed the site again, and voilá my translations were visible.

    Handy to know that when there’s an update on this brilliant theme I only have to get the .po file form the server and place it back when the theme is updatet. Even managed to update the footer (although it’s probably not the propper way to do it here).

    Just struggling with one translatation above the comment form. In English it says ‘Leave reply’ which has been translated to ‘Geef reactie’ which is a bit blunt.
    I found out this sentence is in the .po file in the language folder under the ‘wp-content’ folder. I changed it but it doesn’t show the updatet content. Probably needs a refresh as well, but changing the settings doesn’t work. So no idea how i’m going to get that visible, but ok that one is a non-chosen theme issue.

    Thanks for the support and this amazing template!

    Theme Author Ben Sibley

    (@bensibley)

    The .po file contains the human-readable translations but there’s also a .mo companion file that the site reads. If you update the .po file with Poedit, there’s an option in the menu to generate a new .mo file. Once you add the new .po and .mo files to your site the translation should show up.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Amazing theme!’ is closed to new replies.