Support » Fixing WordPress » Am i understanding this right?

  • I recently thought the permalinks would be a great idea for my blog

    So i edited httpd.conf and so on…
    Tho, i run into trouble. The pages and pagination thing works fine but the archive links and links to normal posts dont. I get a 404 error.

    Now im wondering in the permalinks page @ options do i NEED to set things here or is there a standard set of values…

    also why doesnt it just work when i use the default syntax suggested at the page? i tried cutting in the url (while using the full syntax) things as “” but that does not work!

    As last option i tried including the /index.php/ thingy and poof, it works… but from what i understand it should work without aswell?

    Please advise…

    I have
    WP 1.5.2
    Apache 2.0.53 (mod rewrite on, followsymlinks All)
    PHP 4.x
    linux clarkconnect

Viewing 7 replies - 1 through 7 (of 7 total)
  • Why did you edit httpd.conf?

    I’m hoping the OP meant .htaccess…

    I edited the file to set followsymlinks to All it was None by default.
    Also i made the .htaccess as instructed by WordPress.

    Lets clearafy, i know what im doing when i edit the httpd.conf… Im running servers for some time now 🙂

    Anyway, im still wondering why it doesnt ‘work right’ for me 🙁 Can it be a think with virtualhosts and/or subdomains?

    When FollowSymLinks was set to None no permalink worked right. After i changed it, some do.

    I’m not an expert on .htaccess by any stretch of the imagination, but I can say it’s got nothing to do with subdomains. Is WP writing to your .htaccess?

    Yes Wp edits the file fine. Its set to 777. in the root of the wp folder.

    I just installed the latest version of photopress, 0.8.1. The permalinks Do not work for this plugin either.

    I regenerated the permalinks code as suggested also i tried addind /index.php/ to the albums permalink struct.

    Both dont work… Why is it so hard to set up proper permalinks if the server isnt supporting it… 🙁

    Just to clear out:

    Since WP2.0 this issue has been solved!
    Also fixed as of version 0.8.5 in photopress!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Am i understanding this right?’ is closed to new replies.