Support » Plugin: WP GCM » Always shows the "Info currently 0 users are registered" message.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Pixelart

    (@pixelart-dev)

    Ok will check that out, please wait!
    But in the mean time, you could try this official tutorial by google
    http://developer.android.com/google/gcm/client.html.

    In the most cases the problem is the URL, how the id is transmitted.
    Be sure the device id is transmitted this way:
    http://www.myblog.com/?regId=AbCdEfG12345′ .

    Plugin Author Pixelart

    (@pixelart-dev)

    – resolved

    Hi, pixelart,

    It’s really good to hear from you that a new version plugin is now available.
    But as I download the 1.2.3, I also encounter the same problem as previously mentioned,
    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘px_gcm_toolbar’ not found or invalid function name in /raid/vhost/3drens.url.tw/www/wordpress/wp-includes/plugin.php on line 470

    By the way, i am install the plugin directly from the wordpress web UI, rather than download the zip file and extract it.

    Another thing is that, is it possible for us to ask for a sample Android project (for set the correct GCM parameters)? It might be helpful for us to achieve this wonderful GCM feature.

    Thanks a lot!

    oeo

    Plugin Author Pixelart

    (@pixelart-dev)

    Ok Thank you very much for report the bug, it is fixed in the latest version

    The Android project is now available on github.
    link is added soon

    Plugin Author Pixelart

    (@pixelart-dev)

    Hi pixelart,

    Thanks for the prompt response for the questions I asked.
    We had tested this gcm android app and it DOES work! It’s really amazing!
    Thanks again for developing such useful wp plugins.

    And two more thing we found in the 1.2.3 & 1.2.4 version is that after publishing a new post, there shows the
    Catchable fatal error: Object of class stdClass could not be converted to string in /raid/vhost/3drens.url.tw/www/wordpress/wp-content/plugins/wp-gcm/options.php on line 174 logtrace. Although the post has correctly been posted.
    And the other is after sending the GCM message successfully, the webpage turn to the wordpress/wp-admin/admin.php?page=px-gcm# => it’s a blank page. Is it the right flow ? I remember that in the previous version it will show the sent message and the OK/ faid sending result.

    Again, thanks for the good design for combining wp and android. ^__^

    oeo

    Plugin Author Pixelart

    (@pixelart-dev)

    Hi oeoeoeooeo,

    Its great to hear from you!

    I think the first bug is caused by the debug response mode, which was code wrong and now corrected in 1.2.5.

    I cant reproduce your second bug. After sending a message on my testing blog, I get the following screen:
    link to picture

    Maybe you can send or post a screenshot also here so I can see whats wrong.

    And it would be very very great when you leave a review 🙂

    Hi, Pixelart,

    After i re-install the 1.2.5 plugin, i can not reproduce this “blanked page” phenomena. Perhaps this is due to my cached website data…

    Anyway, we are now happy using this well-designed wp-gcm plugin.
    And we will continue test and try it. Hahaha!
    Thanks a lot. ^__^

    Good work!

    oeo

    Plugin Author Pixelart

    (@pixelart-dev)

    Thank you very much!
    Have fun with it and please rate this plugin!

    BR

    Of course 5 star plugin!!!

    Hello Pixelart,

    Your plugin is what I really need for my project, but I can’t seem to get it to work.
    I have the same problem like the one mentioned above, I downloaded your app, change the SenderID and URL to my website. I have inserted my API key (for server app) in your plugin, in my own website.

    And then when i ran the app it shows the regId and saying that it’s registered. But in your plugin it says “Info currently 0 users are registered”

    Any help is appreciated. Thank you

    Hi, it seems my issue is because I use server-key, once I use browser key, the plugin works just fine.
    Thx for the help Pixelart

    Plugin Author Pixelart

    (@pixelart-dev)

    Great to hear that your found a solution david23zack

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Always shows the "Info currently 0 users are registered" message.’ is closed to new replies.