Support » Plugin: MailChimp List Subscribe Form » Always shows “Preferred Format”

  • Resolved Avrom

    (@dividendninja)


    Hi,

    The Plugin always shows “Preferred Format” for html or text on the form. The option is definitely not checked in MailChimp itself. There are no options in the WordPress plugin interface to switch this off either.

    Example:
    https://web242.com/subscribe/

    Can you please fix or is there solution via the shortcode?

    Cheers
    Avrom

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Avrom

    (@dividendninja)

    Hi,
    I solved this with CSS, but built-in functionality would be better. đŸ˜‰

    .mc_email_format,
    .mc_email_options {
    display: none;
    }

    Hey there Web242,

    Thanks for writing in here. I’d be glad to help take a look into things with you here.

    After some testing, it looks like the best way to ensure that the HTML/Plain-Text option is added or removed is by navigating within the MailChimp account to “Lists > Select a list > Signup Forms > select or deselect checkbox for ‘Let subscriber pick email format (Plain-Text or HTML).'” From here, it will be necessary to go to Plugin Settings for “MailChimp”, select the list and click “Update List.” This will allow the List Subscribe Plugin to update based on any new changes in settings from the MailChimp app and should remove the HTML/Plain-Text option.

    Glad to hear you were able to come up with a workaround here using CSS if that standard workflow does not work. In any case, I can see how having this option within the Plugin settings on the WordPress site would be helpful and would be glad to pass that feedback along to our team to keep in mind for the future.

    If there’s anything else we can assist with, please don’t hesitate to let us know!

    Thanks,
    Malachite

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Always shows “Preferred Format”’ is closed to new replies.