WordPress.org

Support

Support » Plugins and Hacks » User Submitted Posts » [Resolved] Always gets general submission error "There was an error"

[Resolved] Always gets general submission error "There was an error"

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jeff Starr

    @specialk

    Hi reflexiv, not sure what the issue might be, but I’m always glad to jump in and take a look at settings, etc., to see if anything looks weird. Contact me via http://perishablepress.com/contact/ for more infos.

    Hi Jeff, I did some modifications because the answer to the spam challenge question was showing up in the input box, set as the placeholder. Also, some backslashes were strangely being added to my question so I added the question directly in submission-form.php.

    I just tried uninstalling and reinstalling. It now works for me with default settings. The spam challenge answer is still showing in the input box as the placeholder. To fix I removed this on line 65 of submission-form.php:

    placeholder="<?php echo $usp_options['usp_response']; ?>"

    It’s now working perfectly, so maybe I messed something up when I was previously modifying submission-form.php. Thanks for this useful plugin!

    Plugin Author Jeff Starr

    @specialk

    Glad to hear you worked it out. I’m redoing the whole placeholder strategy in the new version, may remove them completely I don’t know yet. Just a note though that the spam challenge question is not meant as a test for humans, it’s a test for bots.. so it doesn’t matter at all if the answer to the question appears as the placeholder.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Always gets general submission error "There was an error"’ is closed to new replies.
Skip to toolbar