• Resolved dimitriosvasileiou

    (@dimitriosvasileiou)


    No matter how many times I untick the ‘Enable Post Expiration’ box, upon post update and page refresh the box is ticked and posts set to expire on the set date (+3 Months).
    This has been happening with all latest plugin updates apart version 2.4.2 (I think).
    Is there a known conflict with any other plugins?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Steve Burge

    (@stevejburge)

    Hi @dimitriosvasileiou

    Sorry, we don’t know of any conflict that may cause this.

    – Please test by disabling other plugins
    – Try to see if the error occurs on a second site
    – Check to confirm if 2.4.2 really is the only working version for you

    Thread Starter dimitriosvasileiou

    (@dimitriosvasileiou)

    I confirm that 2.4.2 is the only one working properly.

    Plugin Author Steve Burge

    (@stevejburge)

    OK, thanks @dimitriosvasileiou

    We have not had any more reports of this. Please try these debugging steps to help us see what’s different with your site:

    – Test by disabling other plugins
    – Try to see if the error occurs on a second site

    I am having this same issue, and have been for some time. We have tried disabling all plugins and the error still occurs.

    I have a shimmed version that I fixed to fix the error, but this is far from ideal. Can you give us an idea when this issue might be fixed?

    Same here. https://cln.sh/h8YzbN

    Worked around by setting an expiration date far in the future, for now.

    I have not tried disabling plugins yet.

    The site is still using classic editor / Disable Gutenberg. Astra theme. And a slew of other plugins.

    I’ve experienced this on more than one site, most of them using similar tools.

    Plugin Author Steve Burge

    (@stevejburge)

    @ruanna @dougblackjr @dimitriosvasileiou Please test this pre-release version of the plugin and let us know if it helps: https://www.dropbox.com/s/4se1xrdtzw9jknc/post-expirator-2.7.1-rc.3.zip?dl=0

    Thanks for that.

    With 2.7.1-rc.3 active, the box still won’t uncheck:
    https://cln.sh/xd4QK6

    However in the CPT list, the expiration shows as Never:
    https://cln.sh/FyeYXC

    If it was showing as “Never” in the list before, I just didn’t notice.

    I also tried changing “How to expire.” If I do that and select an expiration date in the future, everything works. How to expire is correctly revised, future date is reflected on the single and in list view too.

    If I uncheck “Enable Post Expiration” and save, the CPT reverts back to checked mode, and also back to “Draft.” And in the list, it goes back to Never.

    Plugin Author andergmartins

    (@andergmartins)

    Hi Ruanna,

    Thanks for the feedback. We are looking at that issue, but we are not able to replicate it on our sites. But we have another reports for a similar issue…

    Please, could you check if you have object cache enabled on the site? If so, please could you let us know what hosting company you are using?

    As like as above Ruanna said,
    For me,
    version : 2.7.0
    In the CPT list, the expiration shows as Never. => https://ibb.co/PF8wrdd
    the check box still won’t uncheck in detail screen. => https://ibb.co/7yqZsBn
    How to do this?

    • This reply was modified 7 months, 1 week ago by YanKyawMin.
    Plugin Author andergmartins

    (@andergmartins)

    Hi Guys,

    Thank you for all the feedback.

    We have a new RC version addressing this issue. Please, could you try the following package?

    https://www.dropbox.com/s/artos53oj90t9am/post-expirator-2.7.1-rc.4.zip?dl=0

    Plugin Author Steve Burge

    (@stevejburge)

    Please update to version 2.7.1 of the plugin.

    If that doesn’t work, try using “Bulk Edit” to update the expiration details for your content.

    If that doesn’t work, please open a new thread here, or open a support ticket if you’re a PublishPress member.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Always Expires’ is closed to new replies.