Support » Plugin: Amazon Associates Link Builder » Altervista.org incompatibility?

  • Once activated, the plugin shows the following error on Altervista.org-based WP blogs:

    Parse error: syntax error, unexpected ‘[‘ in /members/membername/wp-content/plugins/amazon-associates-link-builder/lib/php/aalb_tracking_api_helper.php on line 71

    any suggestion? Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • so if you have the error, you can fix it :
    /wp-content/plugins/amazon-associates-link-builder/lib/php/aalb_tracking_api_helper.php on line 71
    replace
    //return json_decode($response, true)[“link-id”];
    by
    $obj = json_decode($response,true);
    return $obj->{‘link-id’};

    and

    in wp-content/plugins/amazon-associates-link-builder/includes/aalb_config_loader.php
    replace
    //$updated_marketplace = [];
    by
    $updated_marketplace=array();

    Thanks makmakmak21!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Altervista.org incompatibility?’ is closed to new replies.