Support » Plugin: Wordfence Security - Firewall & Malware Scan » Alternatives to user.ini for versions of PHP below 5.3

  • Is there any way to configure the Wordfence Firewall for servers using CGI/FastCGI with PHP versions below 5.3?

    I have PHP 5.2, and for a variety of reasons I cannot upgrade the PHP version on the server.

    As the troubleshooting page says, because of the PHP version being below 5.3 the Wordfence installation completes without errors but the firewall still shows Basic WordPress Protection.

    Is there any way to activate the firewall while still using 5.2?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi Mike,
    The alternate method described during the Firewall Setup should always work fine, which is appending this code to your “php.ini” file:
    auto_prepend_file = '/var/www/wordfence-waf.php'

    Note: the file path will be different in your case.

    Thanks.

    Thread Starter MikeRogers

    (@mikerogers)

    Thanks….I tried that before and it hammered the site, but I’ll try it again and see what happens.

    Thank you, wfalaa!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Alternatives to user.ini for versions of PHP below 5.3’ is closed to new replies.