Support » Plugins and Hacks » Easy Digital Downloads » [Resolved] Already Purchased

[Resolved] Already Purchased

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Pippin Williamson


    Please post your Downloads > System Info.

    ### Begin System Info ###

    ## Please include this information when posting support requests ##

    Multisite: No

    SITE_URL: http://padloops.com
    HOME_URL: http://padloops.com

    EDD Version: 1.7.2
    Upgraded From: None
    WordPress Version: 3.6
    Permalink Structure: /%year%/%monthnum%/%day%/%postname%/
    Active Theme: Dark Theme 1.0

    Test Mode Enabled: No
    Ajax Enabled: Yes
    Guest Checkout Enabled: Yes
    Symlinks Enabled: No

    Checkout is: Valid
    Checkout Page: http://padloops.com/checkout/
    Success Page: http://padloops.com/purchase-confirmation/
    Failure Page: http://padloops.com/checkout/transaction-failed/
    Downloads slug: /downloads

    Taxes Enabled: No
    Taxes After Discounts: No

    Registered Post Stati: publish, future, draft, pending, private, trash, auto-draft, inherit, refunded, failed, revoked, abandoned, active, inactive

    Platform: Apple
    Browser Name: Safari
    Browser Version: 6.0.5
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10_7_5) AppleWebKit/536.3
    0.1 (KHTML, like Gecko) Version/
    6.0.5 Safari/536.30.1

    PHP Version: 5.2.17
    MySQL Version: 5.5.32-log
    Web Server Info: Apache

    PHP Safe Mode: No
    PHP Memory Limit: 256M
    PHP Upload Max Size: 10M
    PHP Post Max Size: 10M
    PHP Upload Max Filesize: 10M
    PHP Time Limit: 30
    PHP Max Input Vars: 1000

    WP_DEBUG: Disabled

    WP Table Prefix: Length: 4 Status: Acceptable

    Show On Front: page
    Page On Front: Home (#203)
    Page For Posts: Blog (#103)

    WP Remote Post: wp_remote_post() works

    Session: Disabled
    Session Name: PHPSESSID
    Cookie Path: /
    Save Path: /tmp
    Use Cookies: On
    Use Only Cookies: Off

    WordPress Memory Limit: 40MB
    FSOCKOPEN: Your server supports fsockopen.
    cURL: Your server supports cURL.
    SOAP Client: Your server has the SOAP Client enabled.
    SUHOSIN: Your server does not have SUHOSIN installed.



    Akismet: 2.5.9
    All In One SEO Pack: 2.0.2
    Contact Form 7: 3.4.2
    Easy Digital Downloads: 1.7.2
    Easy Digital Downloads – Amazon S3: 1.4.1
    Easy Digital Downloads – Mail Chimp: 1.0.5
    Google Analytics for WordPress: 4.3.3
    MCE Table Buttons: 2.0
    Social Discount for Easy Digital Downloads: 1.0.8
    WordPress Importer: 0.6.1
    ### End System Info ###

    Plugin Author Pippin Williamson


    Does it happen even with the default theme?

    I’m not sure. I’ve never used the default theme, and it’s not really an option.

    Plugin Author Pippin Williamson


    I just need you to switch for a moment to check. If it works correctly with the default theme then we know where the problem is and I can help you track it down.

    The error does not happen every time, I only get people telling me about it a couple times a week. So if I switched, no telling how long I would have to wait for the error to occur. That, and my theme is how my whole sales page and stuff is setup. No one is going to purchase while I’m using the default theme. I can’t be letting people on my site with the default theme activated, it’s my business on the line. Is there any other way to troubleshoot this?

    Plugin Author Pippin Williamson


    All I’m asking is for you to activate the default theme for 30 seconds in order to test it, then immediately switch it back.

    How do I test it? And also, will I not loose all of my work on the current theme?

    Plugin Author Pippin Williamson


    Simply activate Twenty Twelve. No settings will be lost when you switch back.

    Cool, and how do I go about testing it after I switch?

    Plugin Author Pippin Williamson


    Assuming you were able to see the error before, just view the same page to see if the problem still exists.

    Well, Im not able to see the error. Only random customers are seeing it.

    Plugin Author Pippin Williamson


    Hmm, that does make it more difficult to test.

    Can you make it show up if you purchase the item then browse the site?

    Well I have already purchased it through testing, so it has been correctly telling me that I have already purchased

    Plugin Author Pippin Williamson


    Ok let’s do this differently. Let’s just remove that message entirely.

    1. Create a new custom plugin using Pluginception: http://wordpress.org/plugins/pluginception/

    2. Paste this code into it: https://gist.github.com/pippinsplugins/8be9a2db6429797d13c0

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Resolved] Already Purchased’ is closed to new replies.
Skip to toolbar