Support » Installing WordPress » Already installed message

  • My WP install worked fine for months and then something got corrupted and I kept getting blank admin pages after saving an entry, or clicking any update button. I should have dealt with that but I didn’t–just kept posting entries and other stuff because I could. Then the blog itself disappeared and I got the following message when I tried to reinstall WP, hoping that would work:

    “Already Installed

    You appear to have already installed WordPress. To reinstall please clear your old database tables first.”

    I don’t know how to clear my old db tables, and I don’t want to lose five years worth of entries. Is there any way to restore the db?

Viewing 15 replies - 1 through 15 (of 16 total)
  • “Clearing the database” would mean deleting all yor content: entries, comments etc.
    You don’t want that, I am sure.
    Never try to install WP on an already working version – you’ll always get the above message.
    If you didn’t change anything in your setting, no new plugins etc. did your host change anything? Did they do an upgrade of the server software?

    I think I was playing around with new plugins–can’t remember which ones, though. I tried switching the db on another wp install–different folder–and that worked, but I couldn’t get back to wp-admin in that folder again; it kept redirecting me. Then I tried reinstalling in a completely new folder and got the “already installed” message. So now I’m in a real mess.

    [Update: Forgot to answer about my host–haven’t checked if they’ve done anything. I’ll go see now. I’m on Textdrive, fyi.]

    Well, what you just told is enough to screw up an install – you don’t need the host’s “help” 🙂
    If you access to phpMyadmin you should check the site_url and home values in the options table:

    Thanks, I followed the instructions and changed the siteurl and home values to the folder where wp is installed now, but nothing changed. I can’t access wp-admin.

    When I click on your name here it goes to an un-styled blog, which means it still points to a noen-existent path for the style.css
    Where exactly is your WP install?

    Update: css for this theme [squible] is custom.css

    No offense, but in the last several days a lot of people have problems with that theme. I am not familiar with it but either it is not done properly or it’s difficult for users to set it up properly.
    Your blog is looking for the stylesheet in the wrong place:
    <link rel="stylesheet" type="text/css" media="screen" href="" />
    The path is missing the /tuckered/ folder name.
    Is that hardcoded or… where that link comes from?
    So, if the blog is in a folder, why is it giving a 404 not found and showing up here:

    I don’t know. I changed the blog url in options to, and it worked okay but then when I tried to get into tuckered/wp-admin, all hell broke loose. I can’t change the theme now. What if I delete it by ftp? Would that force it to go to the default theme?

    [Update: Now I remember–I was using the squible theme as-is in \tuckered, and then I uploaded the customized squible theme from That’s when things went south. I’m deleting that folder now to see what happens.]

    Update 2: That didn’t work. I got a blank page. So I uploaded the original, non-customized squible folder and everything is back to its messed-up self.

    Wait. You have changed the 2 URI options just like that without going through this: Giving_WordPress_Its_Own_Directory ??
    Then no wonder it doesn’t work.
    1. Go into the phpmyadmin and change the 2 values to exactly where the WP install physically is.
    2. See if it works properly.

    After that, if you want to change anything, read the Codex, ask question and make the move only when you are 100% sure what are you doing.

    No, I made the wp directory changes before I tried anything else. Then I changed the phpmyadmin values to the tuckered folder, following instructions here:

    Thank you for your help, but you have made a wrong assumption. I correctly changed the directory according to the Codex instructions before I changed the values in the phpmyadmin. It does not work properly.

    I just want to save the database with five years worth of entries. I don’t care about themes, directories or anything else. Have I screwed it up to the point that I have to give up on my db?

    If the database is there – nothing is lost 🙂
    It’s probably just a wrong setting somewhere (or miscommunication between the two of us).
    These lines “Now I remember–I was using the squible theme as-is in \tuckered, and then I uploaded the customized squible theme from That’s when things went south” made me a bit confused…
    Does it mean you have 2 WP installs? I can’t really follow what’s going on there.
    I will have to leave now soon, but maybe tomorrow I could take a look at it if you want and if you contact me (click my name > contact)

    Sorry–yes, I have two wp installs, or did. Thank you, I will contact you tomorrow.

    Hey, I guess it just took a while for the site_url changes to go through. I looked at my site a couple of hours ago, and everything’s working fine. Phew–thank you!

    How do I clear the database? or whatever to get this thing figured out… looking for where to clear it has got my brain all boggled.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Already installed message’ is closed to new replies.