WordPress.org

Forums

SSL Insecure Content Fixer
[resolved] Alot insecure (20 posts)

  1. MtpIntros
    Member
    Posted 1 year ago #

    Hi,

    I've just activated this plugin, in the hope that my page will FINALLY be a normal and good functioning page.

    My issues:
    - Google Chrome gives me the ugly Yellow triangle, instead of the green lock.
    - Only the home page shows up with HTTPS.
    - All the other pages give me the error: This webpage has a redirect loop ERR_TOO_MANY_REDIRECTS

    What i've tried:
    - Installing the plugin WordPress HTTPS (Does totally nothing)
    - Deactivating all the plugins
    - Changed the url from http:// to https:// in Settings > General

    My site: https://centralbusinesstransfers.nl

    I would really REALLY appreciate it if someone could help me..

    --EDIT--

    What I do know is that everything has to be linked with HTTPS:// or just //.
    I removed all the HTTP with the use page elements (F12 (Chrome)), and saw that my whole website looked how it supossed to be.
    I do know what the problem is right now, but I don't know how to resolve this.

    Greetings, Adil

    https://wordpress.org/plugins/ssl-insecure-content-fixer/

  2. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    Looks like you're behind a load balancer, so WordPress can't tell that the page has been requested with SSL. If you look in the Tools menu in WordPress admin, you'll see a link to a test page to see if is_ssl() can detect SSL correctly. It should tell you whether your website is giving you any hints about SSL or not.

    Likely, you'll need to install the plugin from this gist. It detects when you've set WordPress to be SSL all the time, and tells WordPress that it's running on SSL.

    https://gist.github.com/webaware/4688802

    cheers,
    Ross

  3. MtpIntros
    Member
    Posted 1 year ago #

    Thanks for your response Ross!

    I'm sorry to sound like a real noob, but how do I install a php file..
    Do I have to extract it to a .zip file, and then upload it via WP-admin ?

  4. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    G'day Adil,

    If you have FTP access to your website, just upload the PHP file into the wp-content/plugins folder. Otherwise, yes, you will need to add it to a .zip file and load that through the WordPress admin.

    Did you run "Test is_ssl()" on the Tools menu? What did it say?

    cheers,
    Ross

  5. MtpIntros
    Member
    Posted 1 year ago #

    Ah okay,

    This was the result of the test:
    SSL Insecure Content Fixer - is_ssl() test

    This page checks to see whether WordPress can even test for SSL. If it can't, something else needs fixing.

    is_ssl() says: no, SSL not detected

    Your server may be behind a load balancer or reverse proxy.

    Please ask your web hosting provider why your website can't detect SSL, and show them this article:

    WordPress is_ssl() doesn’t work behind some load balancers

    So what I know have to do is upload the php file to the plugin map and that should fix it ?

  6. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, FTP that .php file into wp-content/plugins and activate it through the plugins admin. You must also ensure that the Site Address and WordPress Address are set to use https in Settings>General.

    cheers,
    Ross

  7. MtpIntros
    Member
    Posted 1 year ago #

    I've changed the site and wordpress adresses to https://, activated the .php plugin, and again did the ssl test.
    Same result as mentioned above, plus my website doesn't load anymore..

    It gives me the Error: This webpage has a redirect loop ERR_TOO_MANY_REDIRECTS

    Greetings,
    Adil

  8. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    The is_ssl() test page won't give a different result, it runs outside of WordPress so it doesn't get fixed by the plugin; it's just a diagnostic tool.

    If you are getting redirects, then you should delete that .php plugin and contact your website host for support. It sounds like you might have a setting somewhere that is redirecting pages back to http from https.

    cheers,
    Ross

  9. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    Or: do you have both SSL Insecure Content Fixer and WordPress HTTPS installed? If so, disable the latter and try again, because it's been known to create redirect loops.

  10. MtpIntros
    Member
    Posted 1 year ago #

    I currently only have activated SSL insecure Content Fixer and Force SSL URL Scheme.

    I have already contacted my hosting for support, and they told me that I have to check the codes of wordpress..

  11. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    What's in your .htaccess file? It's in the root of the website.

  12. MtpIntros
    Member
    Posted 1 year ago #

    It's completely empty..

    Just 5 empty lines.

  13. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    Oh, you're running WordPress on a Windows server. [that's your problem right there :) ]

    You'll need to find someone who has experience configuring Windows servers to run WordPress properly, i.e. not me. Although WordPress can run on Windows, I'd never recommend it; too many problems. Best go back to your website host and ask them for assistance (and tell them that it's not WordPress code, it's their configuration that is broken).

    Also: looks like you haven't deleted that .php plugin yet, for Force SSL URL Scheme. The site is still redirect looping.

    cheers,
    Ross

  14. MtpIntros
    Member
    Posted 1 year ago #

    Ahh... Okay...

    So when I say to my hosting that the problem is in their configration, they will ask me; what configuration.. What do I have to answer on that question..

    I have to be prepared to fully answer their standard stupid questions, because they are not really willing to help people. Mostly they give they say that the customer made the fault it self, and has to fix it hisself, like they did to me.

    Soo.. can you (exactly) explain what the problem is?

    Greetings,
    Adil

  15. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    Send them to this article, so that they know what the problem is. How they solve that on Windows is not something I know.

    cheers,
    Ross

  16. MtpIntros
    Member
    Posted 1 year ago #

    I'll try contacting my hosting tommorrow, and will give a feedback on this post :)

    Thank you very much for the help, Ross!

  17. MtpIntros
    Member
    Posted 1 year ago #

    Hey webaware,

    Sorry for the late response, my hosting didn't answer my ticket directly.

    They said that there actually IS a problem in WordPress which makes the SSL go all nuts. He didn't say what the problem was (probably because he didn't know what the problem was).
    Some urls do work like:
    http://centralbusinesstransfers.nl/readme.html

    -EDIT-

    I don't know what happend, but I suddenly don't have a .htaccess anymore. I absolutly didn't do a thing.

    Greetings,
    Adil

  18. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    G'day Adil,

    That link that works is a plain HTML file, not a page in WordPress. So of course it works, there's no PHP happening let alone WordPress calling is_ssl().

    Frankly, I suggest you move to another host if this is the best they can come up with.

    Edit: and when you move, make sure you move to a Linux hosting account. It's better suited to WordPress, and typically also cheaper. You only need a Windows hosting account if you are running something Windows-specific, like an integration with Microsoft SQL Server.

    cheers,
    Ross

  19. MtpIntros
    Member
    Posted 1 year ago #

    Ah shit.. That blows,

    I was hoping that i didn't have to move to another host, because I stuck to them for a year.

    Well.. It is what it is.

    I would like to thank you for your help, sir!

    Have a nice day,
    Adil

  20. webaware
    Member
    Plugin Author

    Posted 1 year ago #

    No worries, best of luck with the move. I suggest you use a tool such as WP Migrate DB to move the database across to your new host.

    cheers,
    Ross

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • SSL Insecure Content Fixer
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic