Support » Fixing WordPress » Almost Incomplete Inaccessibility in WordPress 3.8 Using Various Screen Readers

  • Resolved LotusDreamer



    After updating to 3.8 last night, I am now rather terror-stricken to discover that much of my WP Admin screen and it’s options are inaccessible. I am totally blind, and have tried using both System Access and NVDA for testing, in both IE and Firefox on a Toshiba PC running Windows 7.

    In Firefox, many links now only speak the word “Link?” or “Link? Submenu”, but the number of these links seem to be few and far between. I have discovered, (basically through trial and error and guess work), how to get to my profile, and how to post a new page, post or link. But finding a reliable solution to get to my Plugins Submenu, Pages submenu, and other menus which were totally accessible to me in the last build, has not occurred as of yet. This state of affairs is rather terrifying to a site owner who does regular updates, particularly now in the holiday season.

    I have managed, again in Firefox, on a couple of occasions, to discover my “Settings” and other submenus, but can’t figure out how to successfully duplicate finding them, (as the appropriate titles to links that appear to be constantly available on the dashboard are no longer spoken).

    When testing in IE, there is a link called “Menu” that is spoken, but I can’t seem to activate it. Using NVDA I have tried pressing enter on this link, space, and shift caps lock M to try to open it (although it doesn’t speak the fact that there is a submenu) but no go.

    Am happy to share audio demos, clarify in any way or otherwise answer questions. This is very disheartening for me at the moment, and any assistance will be most gratefully received.

    Thanks so much,

Viewing 15 replies - 1 through 15 (of 41 total)
  • Quick update. Have managed to activate this “Menu” link using f6, then tabbing back into my page from the address bar. Not exactly convenient, but a workaround. From here I can access most features, although still can’t find my WP slimStat stats for the life of me. Just wanted to share…

    Second update. Based on where the menu link was located in relation to other links on my admin screen utilizing IE, I was able to find the link in Firefox. This is helpful, but still doesn’t totally resolve the problem. As mentioned previously, there are items, like my WP SlimStat plugin info, that I can’t find at all now, in addition to info regarding other plugins. I can find the options to configure said plugins where one would expect to find them (under the Plugins submenu), but, for instance, not my stats info for my WP SlimStat plugin. I’m much better off than I was, but still rather baffled at how to rediscover my missing info.

    Thanks for reading.

    Hi Kim, just wanted to let you know that a link to this thread has been distributed to WP forum moderators. Matt Mullenweg has also just linked to this topic from

    We’re looking into this ASAP; most of the Accessibility group is Europe based, so not many of us are available right now, but will get to it as soon as we can.

    Hi Kim, sorry to hear about your troubles.

    Sounds like WordPress is running in “responsive” mode. It is intended for tablets and phones, but not for screen readers.

    The responsive mode is triggered by the browser window’s width. Suspecting that either the window is quite narrow or the zoom is set to a high value.

    Could you try making the window wider and/or reducing the zoom (Ctrl and minus or Ctrl and 0 in both Firefox and IE).


    Having a similar problem. Had problem last night where I could not switch between ‘visual’ and ‘text’ views of pages. Also Yoast SEO features are not available. Turned on the laptop this morning and all was OK – for one page. Then problem has returned. How can I go back to the old version?

    Hi Kim & Geothom. My name is Jackie, I’m a blind wordpress developer & also a part of the Make WordPress Accessible team.

    Neither of you have provided the following information, which would be helpful:
    a) Your operating system;
    b) The browsers you use & their versions;
    c) The adaptive technologies you use, if any, as well as their versions;
    d) The type of device you’re using, i.e., desktop, laptop, tablet, etc.; &
    e) The url’s of your sites.

    Just so you know, the link that says “submenu” actually indicates a list of items that is to follow. Also, I am not experiencing these issues using the latest version of NVDA & Firefox. I’ll check w/Jaws & Window-Eyes later, as well as IE.

    I would ask that you please update your browsers, if applicable, as well as your adaptive technologies, if the latter is possible. Certainly it is w/NVDA, but I understand updating 1 of the paid screenreaders may well not be an option. NVDA does handle WordPress very well, & I’d recommend becoming familiar w/it. Truthfully, I’ve seen it handle stuff that Jaws or Window-Eyes didn’t handle well. Go figure!

    Thank you for providing the requested information so that we can better diagnose & provide fixes/workarounds for the issues you’re encountering.

    I’ll be standing by & checking in from time to time this evening to see if there are any replies & to see if we can’t resolve the difficulties you folks are experiencing.

    Hi abletec, sorry not used to forums. I am using a Samsung laptop running Win8. Browser is FF 27.0. Nothing special about my environment – using Yoast SEO as mentioned. All was OK until I upgraded to 3.8 and then restarted laptop yesyerday. As mentioned in previous post, all was ok again when I started the laptop this morning and edited a page but after navigating away from that edit I can no longer switch between ‘text’ and ‘visual’ nor can I view/access the SEO information. URL is Hope this helps. I am thinking of re-installing 3.7.1- any reason why I should not?

    P.S. I meant to add that I have tried turning laptop off/on several times but still have the same problems each restart.

    Just tried IE10 and Chrome 31.0.1650.63 – same problem

    Hi, geotom, & thanks for your information. I have a few more questions:
    a) What is your theme?
    b) Are u running any plugins besides Yoast Seo?
    c) What adaptive technology(ies) are you using?
    d) Do you have skype?

    Obviously since I can’t reproduce what you’re experiencing, I’m trying to find some differentiating factors that might help us figure out what’s occurring. 1 thing I think I can say w/a fair amount of certainty is that restarting your laptop isn’t going to help this particular situation.

    I’d like to see you go back to a default theme if you’re not already using 1 & see if that works. I understand, however, that since this is your business website, it might cause your customers some consternation if you changed the site appearance on them. So–could you please try disabling your plugins to see if that makes any difference? Then we can try re-enabling them 1 at a time if it does until we find the culprit. Obviously, if it makes no difference, then the next step really might be to try a default theme & see if that works. Having said that, though, I’ve tried this both with a default theme & 1 I’ve purchased, & both work fine.

    @abletec – Thanks very much for diving into this; you’re definitely one of the best equipped to help troubleshoot!

    It does sound like @azaozz might have a good tack into the source of the problem; the responsive view incorporates some significant changes into the behavior of the theme; it’s worth investigating.

    Yeah, that’s why I’m asking the questions I am, cuz that’s the road I’m headed down as well, Joe. I’ll hang in w/this topic till we find some answers.

    Hi again – interesting!
    I am using Soho Hotel Responsive theme. I disabled ALL plugins and still have same problem. Can’t add media – anything! When I disabled Jetpack then reactivated all worked OK – ONCE ONLY. When I deactivated WordPress SEO, same thing – all worked ONCE ONLY then reverted to problem.
    I can’t change theme now.

    I am desperately trying to get some new media uploaded. Have copy of 3.7.1. If I ftp that over existing files do you expect I will encounter any problems?

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Almost Incomplete Inaccessibility in WordPress 3.8 Using Various Screen Readers’ is closed to new replies.