Support » Plugin: Seriously Simple Podcasting » Allowed memory size exhausted while saving post (pt. 2)

  • Resolved Dave Chimny

    (@netzblogr)


    After I got no response on this old closed thread, I’m trying a new attempt, because the behaviour makes podcasting a pain in the […] when I want to save or update an episode.

    It seems that the error always pops up, when the plugin tries to get the filesize of a huge MP3 file (hosted externally, in my case ca. 280 MB each). And even after I’ve set filesize and filesize_raw manually, it happens while updating or saving an episode.

    Maybe the filesize check is performed everytime?

    I found two great solutions that got the filesize of any file in seconds (even behind 3 redirects). Maybe this can help to prevent these errors:

    https://gist.github.com/eyecatchup/f26300ffd7e50a92bc4d

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hello Falk, I sympathise with your problem, we had file upload size issues originally with WordPress not SSP, but I would say that 280MB for an MP3 is massive, what duration are these podcasts? At 96kbps, that would be a 7-hour podcast.

    What data rate are the MP3s recorded at, and are they actually mp3 and not wav files named as mp3?

    SSP User

    Thread Starter Dave Chimny

    (@netzblogr)

    Yeah, that came into my mind, too, some minutes ago. Maybe I should stop using the full 320 kbps stereo MP3 files of my 2-hour radio show. πŸ™‚

    Nonetheless the filesize query could be streamlined anyways, maybe.

    Given where most people would listen like iPods etc, I’d say 96 or 128 would be enough. Saves you file storage too πŸ™‚

    Plugin Author Craig Hewitt

    (@podcastmotor)

    Yep the industry norm tends to be 128 kbps at the top end of the sampling range. For spoken audio this is plenty to get the quality of voice across. Some encode at 96 kbps but if there’s a lot of music in the show then you can hear the decreased quality.

    A lot of times the upload difficulties aren’t so much with file size limits as they are with PHP timeouts.

    If you’re looking for a more robust storage solution Seriously Simple Hosting might be worth checking out.

    Thread Starter Dave Chimny

    (@netzblogr)

    You’re both completely right. But even with the smaller filesize the error occurs and I just wanted to know why it happens and how it can be prevented. Maybe it would occur too, when someone uses SSH.

    Here’s, what I investigated:

    PodBean provides a URL for every MP3 file:
    https://[username].podbean.com/[unique-id]/[filename].mp3

    When I paste this URL into the Audio File field and save the post, the “Memory exhausted” error pops up after ⁓5 to 10 seconds. Very frustrating. Even after setting filesize and a filesize_raw manually.

    I looked up, where the URL is redirecting to (some CDN thing) and pasted the “deeplink” into the field:
    https://[number].podbean.com/pb/[unique-id]/[filename].mp3

    The filesize is determined very fast (duration is not, but that’s another story) and no error message appears.

    So my walkaround is now, that I use the deeplink URL first. I let the plugin find out the filesize wile saving and then I enter the “correct” URL provided by PodBean. But this brings the error back again.

    What I don’t understand:
    – Why does the error occur when a file is behind a redirect?
    – Is the filesize queried everytime a post is saved?
    – Why are there filesize and filesize_raw?

    The size displayed on the feed page has another value than filesize and I don’t know where it is used anywhere else, so I don’t see the sense in it. I’d go with filesize_raw only and let the human readable size be calculated where needed.

    Maybe this could be changed in a future release for easier use.

    Hi there

    So sorry for only getting back to you now.

    The server will need to process more data when a file is behind a redirect, which will use more resources, which is likely causing an issue with the memory limit you’ve experienced.

    You can increase your WordPress site’s memory limit by taking a look at this guide here: https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    The filesize is only queried when the post is saved, if that field data is empty.

    The filesize is a formatted value of filesize_raw. The filesize is used for front-end purposes such as the episode and archive pages, while the filesize_raw is used in the RSS feed which third party services make use of when processing the feed.

    I hope this helps?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Allowed memory size exhausted while saving post (pt. 2)’ is closed to new replies.