Support » Installing WordPress » Allowed memory size error?

  • I’m installing wordpress 2.7. I have entered my database information into wp-config.php and it is correct. When I go to /wp-admin/install.php I get this error:

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 30720 bytes) in /home/timch/public_html/wp-admin/includes/template.php on line 3186

    and line 3186 of template.php says:
    array_shift($allowed_actions);

    Any idea what has gone wrong?

    Thanks.

Viewing 7 replies - 1 through 7 (of 7 total)
  • im sure your answer is found in the countless other threads that address this and are searchable:

    http://wordpress.org/search/Fatal+error%3A+Allowed+memory+size+of?forums=1

    I don’t seem to have access to php.ini and when I edit .htaccess by adding php_value memory_limit 32M it results in any page returning with an Internal Server Error. I guess I need to contact my host?

    Methods for increasing the amount of memory a PHP script may consume

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 16M try 32M:
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)

    2. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 32M

    3. Talk to your host.

    What effect does putting this code in the php do? And where would I want to put it? I understand this changes php.ini when you can’t/don’t have access to it?

    ini_set(‘memory_limit’,’24M’)

    I am having more-or-less the same issue. The last time I talked to my host about this they were sort of helpful. HOWEVER, can somebody please verify with me once and for all where the .htaccess file and php.ini file should reside?? Meaning, if for example my wp installation resides at public_html/blog on my host. I am so damn frustrated, I have put the files everywhere as my host says that they allow my to edit the php.ini. But still, I can’t even get a fresh installation of wp going, so I know it is not a plugin issue.

    You may need a php.ini file in the public_html directory, you will need one in the blog directory, and you will also need one in every other directory that needs the increased memory setting. The .htaccess file should be in your public_html, but may be in your blog directory. It is a hidden file so you won’t see it unless you choose to view hidden files.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Allowed memory size error?’ is closed to new replies.