Support » Fixing WordPress » Allowed memory size error when upgrading to 2.3.0

  • I’m attempting to upgrade wordpress from 2.2.3 to 2.3.0. When I run the ‘upgrade.php’ script, I get this error immediately:

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 233472 bytes) in /var/www/vhost/nampaz.com/blog/wp-admin/users.php on line 225

    I downgraded back to 2.2.3 from backups, went to ensure all plugins were deactivated (only askimet was running. I disabled it), then attempted to upgrade again. I now get this error (almost identical):

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 233472 bytes) in /var/www/vhost/nampaz.com/blog/wp-admin/includes/schema.php on line 103

    I’m not sure what else to do about this, but for now, I’m staying with v2.2.3.

    Any advice would be nice.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Talk to your host and increase the amount of memory available to PHP.

    I am the host.

    I found this answer after googleing around some more. My solution was to increase it temporarily to 16mb, run the upgrade script, and then drop it down to 8mb again. Thus far, I haven’t seen any adverse effects.

    The fact that a very plain, no plug-in, small blog needs this setting tweaked for the upgrade to work REALLY needs to be in the upgrade documentation.

    –Jason

    @zapman – any chance you can tell us what version of PHP you are using?

    # php -version
    PHP 5.0.5-2ubuntu1.8 (cli) (built: Mar 7 2007 17:13:07)
    Copyright (c) 1997-2004 The PHP Group
    Zend Engine v2.0.5, Copyright (c) 1998-2004 Zend Technologies

    phpinfo() gives:
    PHP Version 5.0.5-2ubuntu1.8

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Allowed memory size error when upgrading to 2.3.0’ is closed to new replies.