WordPress.org

Support

Support » How-To and Troubleshooting » allow_url_fopen?

allow_url_fopen?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator James Huff

    @macmanx

    No, it is not required. This is a common misconception. What DreamHost did was disable the capability for a local PHP script to load a remote PHP script, but remote URLs will load just fine.

    I wrote http://kyrres.net/2005/04/05/testartikkel/ to have a place for testing trackback and pingback. It seems like trackback still works fine, but pingback don’t seem to work.

    All worked fine before DreamHost changed this and my WordPress code is unchanged.

    Moderator James Huff

    @macmanx

    I just tested by sending a trackback/pingback both to and from Podz’ official test blog. Both Trackbacks/Pingbacks were received quickly with no problems.

    http://www.tamba2.org.uk/wordpress/TestTrack/

    Are you running PHP as a CGI module or as the Apache user? (You can check in the panel by going to domains -> manage and then selecting ‘edit’ in the web section for that domain – There will be a checkbox saying ‘Run PHP as CGI’)

    allow_url_fopen works when your website is run as a CGI.

    Moderator James Huff

    @macmanx

    ^_^ Good thing I’m running as CGI.

    Well, it looks like the other shoe has dropped….today, April 20th, 2005 (*Not* March 19, 2005 as Dreamhost announced!) my domains running PHP as CGI are showing allow_url_fopen set to off when checked with phpinfo. Stuff is breaking. For one, Mambo CMS newsfeeds no longer function (Remote URLS *do not* load), and I’m still checking other stuff. Hey macmanx, looks like running PHP as CGI is not a “good” a thing as we both thought at first, eh? 😉

    <begin_search_for_broken_script_stuff>

    (note the unclosed tag!)
    rlparker

    Yup, I’ll confirm this too. Thanks for letting us know rlparker.

    My “update-links” days appear to be over, as well. I’m going to have to quit complaining and go with a better (or at least more reliable) host.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘allow_url_fopen?’ is closed to new replies.