Support » Plugin: Checkout with Vipps for WooCommerce » allow_url_fopen

  • Resolved jdahlbom

    (@jdahlbom)


    Hei,

    Jeg får opp følgende i administrasjonspanelet for Vipps:
    “Gateway deaktivert: For at Vipps-betalingsmodulen skal virke må allow_url_fopen være sann i din PHP-konfigurasjon”

    Dette skal være aktivt og jeg har også dobbeltsjekket med phpinfo.php
    se: https://emf-consult.com/nettbutikk/phpinfo.php

    Jeg har ikke noen firewall aktiv men Securi Security og iThemes Security innstallert.

    Hva kan være årsaken?

    Skal også nevnes at Klarna betalingsmodul ikke heller blir synlig i kassen. Så noe problem er det jo som er der.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author iverok

    (@iverok)

    Du har antagelig en sikkerhetsplugin som da skruer av “allow_url_fopen”. Det bør være mulig å skru av dette i instillingene dine. Feilmeldingen du får blir bare trigget av at denne option er av, men dette kan bli gjort av kode som ikke kjører når du kjører phpinfo.

    Du bør helst fjerne den linken nå; det er risikabelt å gi fremmede innsyn i konfigurasjonen din.

    Vi kommer etterhvert til å fjerne bruken av file_get_contents for API-kall (som er grunnen til at dette trengs) og heller bruke WP-apiene her; du vil da kunne skru på dette igjen om du vil.

    Kan det altså være sånn tross at det vises som “ON” i phpinfo?

    Plugin Author iverok

    (@iverok)

    Ja, fordi det kan være noe kode som gjør ini_set(‘allow_url_fopen’, false); et sted i systemet ditt. Det andre alternativet er egentlig bare at det er to forskjellige php.ini’er involvert (som foreksempel, to forskjellige versjoner av PHP).

    Du kan evt. lage en side på siten din med en custom template som gjør phpinfo() inne i selve siden.

    Takk! Det var en php.ini som låg i wp-includes som var problemet!

    Plugin Author iverok

    (@iverok)

    Fra versjon 1.4.0 er ikke allow_url_fopen påkrevet lenger, så da lukker jeg denne.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.