Support » Plugin: Lord of the Files: Enhanced Upload Security » Allow SAT files so they don’t get renamed

  • Resolved jofrysutanto

    (@jofrysutanto)


    Hi there,

    Thanks for this awesome plugin. My client is using a special SAT file (https://fileinfo.com/extension/sat) for their 3D modelling, is there any chance this extension can be added to the allowed list? At the moment they are renamed to .txt files.

    VALIDATION:
    Naive Name: testfile.SAT
    Naive Extension: sat
    Naive Type: application/octet-stream
    Magic Type: text/plain
    Best Type: text/plain

    FINAL:
    Name: testfile.txt
    Extension: txt
    Type: text/plain
    Code: 107

    SYSTEM:
    Kernel: Linux vps.phoenixtapware.com.au 3.10.0-1127.13.1.el7.x86_64 #1 SMP Tue Jun 23 15:46:38 UTC 2020 x86_64
    PHP: 7.4.13
    Modules: Core; PDO; PDO_ODBC; Phar; Reflection; SPL; SimpleXML; Zend OPcache; bcmath; bz2; calendar; cgi-fcgi; ctype; curl; date; dba; dom; enchant; exif; fileinfo; filter; ftp; gd; gettext; gmp; hash; iconv; imap; intl; json; ldap; libxml; mbstring; mysqli; mysqlnd; odbc; openssl; pcntl; pcre; pdo_mysql; pdo_pgsql; pdo_sqlite; pgsql; posix; pspell; session; shmop; snmp; soap; sockets; sqlite3; standard; sysvmsg; sysvsem; sysvshm; tidy; tokenizer; xml; xmlreader; xmlrpc; xmlwriter; xsl; zip; zlib
    WordPress: 5.5.3
    Plugins: acf [5.9.3]; acf-focal-point [1.0.1]; acf-image-mapping-hotspots [0.1]; acf-quickedit-fields [3.1.1]; akismet [4.1.7]; better-search-replace [1.3.3]; blob-mimes [1.2.0]; classic-editor [1.6]; codepress-admin-columns [4.2.2]; gravityforms [2.4.21]; gravityformsmailchimp [4.8]; imagify [1.9.13]; loginizer-security [1.6.5]; post-types-order [1.9.5.2]; really-simple-ssl [4.0.3]; redirection [4.9.2]; regenerate-thumbnails [3.1.4]; taxonomy-terms-order [1.5.7.3]; w3-total-cache [0.15.2]; woocommerce [4.7.1]; woocommerce-additional-variation-images [1.7.22]; woocommerce-email-customizer-plus [1.2.3]; woocommerce-variation-swatches-and-photos [3.0.12]; wordpress-seo [15.3]; wp-all-import-pro [4.6.5]; wp-mail-smtp [2.5.1]; wp-user-avatar [2.2.8]; wpai-acf-add-on [3.2.9]; wpai-woocommerce-add-on [3.2.5]; yith-woocommerce-wishlist [3.0.16]
    Theme:

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Blobfolio

    (@blobfolio)

    Hi @jofrysutanto,

    Thanks for reporting!

    If you update to Lord of the Files 1.2.1, and change your client site’s upload whitelist entry to reflect 'sat'=>'text/plain' — a better fit than application/octet-stream — those files should upload A-OK now!

    Please give it a whirl and let me know how it goes. I’ll leave the ticket open in the meantime.

    Thread Starter jofrysutanto

    (@jofrysutanto)

    Thanks for the speedy update, really appreciate it.

    Just one follow up question, what do you mean by “change your client site’s upload whitelist entry to reflect 'sat'=>'text/plain'” — is this through the plugin settings (which I couldn’t find), or programmatically?

    Plugin Author Blobfolio

    (@blobfolio)

    Oh, sorry @jofrysutanto:

    WordPress doesn’t allow uploads of .sat files by default. (They might slip through because they’re just plain text, but they’ll be renamed to something like .txt.) Programmatically, additional file types are typically allowed by hooking into the upload_mimes filter, but there are also plugins that provide a backend page to manage types.

    If you haven’t explicitly enabled .sat files and you have a custom or child theme going on, you can add the following to the functions.php file and it should do the trick:

    
    function allow_sat_uploads($mimes) {
    	$mimes['sat'] = 'text/plain';
    	return $mimes;
    }
    add_filter('upload_mimes', 'allow_sat_uploads');
    

    If you don’t have access to modify the theme (because it is e.g. made by a third-party), the easiest way would be to use a plugin like https://wordpress.org/plugins/wp-add-mime-types/ (not affiliated with LotF).

    • This reply was modified 1 year, 5 months ago by Blobfolio. Reason: Add plugin link
    • This reply was modified 1 year, 5 months ago by Blobfolio. Reason: "At" the user
    Thread Starter jofrysutanto

    (@jofrysutanto)

    Awesome, that worked perfectly. Thanks for the help!

    Plugin Author Blobfolio

    (@blobfolio)

    Excellent! Thank you for confirming!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Allow SAT files so they don’t get renamed’ is closed to new replies.