Support » Plugin: ShareThis Share Buttons » Allow javascript when active

  • Resolved Yash Baldawa

    (@baldawayash15)


    Hey there,
    How can I allow your plugin script to be loaded only on specific posts or pages, because it loads the script on entire website.

    Thanks in advance!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi there @baldawayash15,

    Thanks for reaching out, I’d be happy to help here! ๐Ÿ˜€

    You will be able to do so by heading to your buttons’ settings -> WordPress Display Settings.

    There you will be able to limit your buttons from being propagated on specific pages.

    Please do let me know if there is anything else I can help you with!

    Cheers,
    Andres

    The buttons are disabled, yet the CSS and JavaScript are still enqueued, which Google dings our PageSpeed/SEO for downloading assets.

    Unfortunately, it doesn’t work as expected. It still loads the styles and scripts on entire website. Is there any way to resolve this?

    Hi there @wraithkenny and @baldawayash15,

    Thanks for your reply! ๐Ÿ˜€

    Unfortunately, at the moment we donโ€™t count with an official workaround for your scripts and styling complete disabling method for the excluded pages request.

    However, there is a pool of ideas we periodically dive looking for new features and if anything changes regarding your request on our end then, be sure Iโ€™ll get back to you.

    Please do let me know if you have any other concerns or ideas!

    Cheers,
    Andres

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Allow javascript when active’ is closed to new replies.