Support » Plugin: Easy Digital Downloads - Simple eCommerce for Selling Digital Files » allow “guest checkout” NOT WORKING

  • If you click “buy and download now” and try to checkout via paypal, it will come back with the error:

    Error: To complete this payment, please login to your account.

    I have searched the docs and it seems you’ve had this ‘bug’ in past ones also, but no real fix. I am not using the ‘Recurring Payments’ plugin.

    And here is my current plugin system data:
    ———————–

    ### Begin System Info (Generated 2020-12-14 00:48:13) ###
    
    -- Site Info
    
    Site URL:                 https://www.l-bowtheclown.com
    Home URL:                 https://www.l-bowtheclown.com
    Multisite:                No
    
    -- Hosting Provider
    
    Host:                     DBH: localhost, SRV: www.l-bowtheclown.com
    
    -- User Browser
    
    Platform:                 Apple 
    Browser Name:             Chrome  
    Browser Version:          87.0.4280.88 
    User Agent String:        Mozilla/5.0 (Macintosh; Intel Ma 
    			  c OS X 10_13_6) AppleWebKit/537.
                              36 (KHTML, like Gecko) Chrome/87
                              .0.4280.88 Safari/537.36
                              
    -- WordPress Configuration
    
    Version:                  5.6
    Language:                 en_US
    Permalink Structure:      /%postname%/
    Active Theme:             Vantage Child 1.7.3.1523879825
    Parent Theme:             Vantage 1.15.5
    Show On Front:            page
    Page On Front:            Home (#4)
    Page For Posts:           Blog (#6)
    ABSPATH:                  /home4/lbowthec/public_html/
    Remote Post:              wp_remote_post() works
    Table Prefix:             Length: 3   Status: Acceptable
    WP_DEBUG:                 Disabled
    Memory Limit:             40M
    Registered Post Stati:    publish, future, draft, pending, private, trash, auto-draft, inherit, request-pending, request-confirmed, request-failed, request-completed, refunded, failed, revoked, abandoned, processing, active, inactive
    
    -- EDD Configuration
    
    Version:                  2.9.26
    Upgraded From:            None
    Test Mode:                Disabled
    AJAX:                     Enabled
    Guest Checkout:           Enabled
    Symlinks:                 Disabled
    Download Method:          Direct
    Currency Code:            USD
    Currency Position:        before
    Decimal Separator:        .
    Thousands Separator:      ,
    Upgrades Completed:       upgrade_payment_taxes,upgrade_customer_payments_association,upgrade_user_api_keys,remove_refunded_sale_logs,update_file_download_log_data
    Download Link Expiration: 720 hour(s)
    
    -- EDD Page Configuration
    
    Checkout:                 Valid
    Checkout Page:            https://www.l-bowtheclown.com/download-checkout/
    Success Page:             https://www.l-bowtheclown.com/download-checkout/purchase-confirmation/
    Failure Page:             https://www.l-bowtheclown.com/download-checkout/transaction-failed/
    Downloads Slug:           /downloads
    
    -- EDD Gateway Configuration
    
    Enabled Gateways:         PayPal Standard
    Default Gateway:          PayPal Standard
    
    -- EDD Tax Configuration
    
    Taxes:                    Disabled
    Tax Rate:                 0
    Display On Checkout:      Not Displayed
    Prices Include Tax:       No
    
    -- WordPress Active Plugins
    
    Contact Form 7: 5.3.1
    Easy Digital Downloads: 2.9.26
    Embed Plus for YouTube - Gallery, Channel, Playlist, Live Stream: 13.4.1.2
    Fonts Plugin | Google Fonts Typography: 2.3.9
    Go Gallery: 1.1
    Jetpack by WordPress.com: 9.2.1
    MC4WP: Mailchimp for WordPress: 4.8.1
    MetaSlider: 3.19.1
    Page Builder by SiteOrigin: 2.11.8
    PHP Everywhere: 2.0.2
    Shortcodes Ultimate: 5.9.6
    SiteOrigin CSS: 1.2.12
    SiteOrigin Widgets Bundle: 1.17.11
    W3 Total Cache: 0.15.2
    
    -- WordPress Inactive Plugins
    
    MailPoet 3 (New): 3.56.0
    
    -- Webserver Configuration
    
    PHP Version:              7.3.25
    MySQL Version:            5.7.23
    Webserver Info:           Apache
    
    -- PHP Configuration
    
    Memory Limit:             -1
    Upload Max Size:          3G
    Post Max Size:            3G
    Upload Max Filesize:      3G
    Time Limit:               30
    Max Input Vars:           1000
    Display Errors:           N/A
    PHP Arg Separator:        &
    
    -- PHP Extensions
    
    cURL:                     Supported
    fsockopen:                Supported
    SOAP Client:              Installed
    Suhosin:                  Not Installed
    
    -- Session Configuration
    
    EDD Use Sessions:         Enabled
    Session:                  Disabled
    
    ### End System Info ###

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi @datawebp

    Thanks for the detailed response.

    As per your error message it looks like “Require Login” setting option is enabled from Plugin Settings > Misc (Tab) > Checkout (Sub Tab).

    Please refer below screenshot so you will be more cleared.
    http://prntscr.com/w4f6zt

    Kindly uncheck “Require Login” checkbox and try again. I hope this will work for you.

    I’m experiencing the same problem. I’m using Kinsta (PHP7.4) and the latest WordPress version.

    The ‘require login setting is disabled. I’ve also deactivated all other plugins.

    There are no errors in the log.

    Hi @dannycooper

    Have you checked the above settings as suggested in provided screenshot.

    Kindly uncheck “Require Login” checkbox and try again. I hope this will work for you.

    Plugin Support Daniel

    (@dgoldak)

    Hey @dannycooper, it’s possible an account already exists. Please review this doc to confirm you haven’t hit one of these scenarios: https://docs.easydigitaldownloads.com/article/1926-login-to-complete-payment

    Plugin Support Mihai Joldis

    (@misulicus)

    Because there have not been any recent updates to this topic we’ll be changing the status to resolved. If you have any further questions you can start a new thread or head over to our support page to submit your request if it is related to one of our available extensions

    I’ve got this problem too. our WordPress install does NOT allow the public to create accounts (it’s a publication), so this is a HUGE problem. This means our most faithful readers sometimes cannot buy downloads.

    @dgoldak I reviewed the link you provided, which identifies it as a known problem, with no solution. This is the most galling part: “This proves to the system that the rightful owner of that particular purchase record is completing the purchase.” We don’t want this kind of security, nor does it seem particularly useful. Since this security is often disabled (in your example, 10 times out of 10), why is it even in there? Can we get an option to turn it off?

    Mihai, Pratik, your suggestion about unchecking “require login” is unhelpful — it is already unchecked on my installation, just as with the others.

    Actually, now I’m testing it by changing the email to random fake emails, and I’m still getting the “please login to your account” prompt, even after closing one incognito browser window and launching a new incognito window. This is terrible.

    Shopping for a replacement plugin now!

    Plugin Author Ashley

    (@nosegraze)

    @scrybbler Can you please provide a link to your site so we can try your checkout?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘allow “guest checkout” NOT WORKING’ is closed to new replies.