• Resolved dwlorimer


    I have been putting off upgrading to Ultimate Member 2.x for a long time. I finally decided to today. Most everything worked fine, but my registrations do not work.

    I am using my own custom Registration Form (not UM’s) that submits to wp-login.php?action=register .

    However, this no longer works with the new version of UM. Instead, whenever I submit a registration, I am just redirected to the UM registration form.

    In 1.3.88, this option existed in Settings->Access:

    “Allow Backend Register Screen for Guests
    Control whether guests are able to access the WP-admin register screen or not”

    I cannot find this setting in the new version. Please instruct me on how to allow my form to submit to wp-login.php?action=register .

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter dwlorimer



    Thread Starter dwlorimer


    I heard back from support on my ticket I submitted with them, so I’m posting it here in case anyone else has run into this issue:

    “In the Ultimate Member 2.x default registration disabled and redirects to UM registration page. It have been done in purpose from security reason. Huckers may use default registration functionality to get access to your site bypassing UM protection.

    If you want to use default registration functionality, please add code below to the end of the functions.php file of the active theme directory.

    // Disable UM registration protection, allow default registration functionality
    remove_action( 'login_form_register', 'um_form_register_redirect', 10 );

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Allow Backend Register Screen for Guests is Missing’ is closed to new replies.