Support » Plugin: Widgets on Pages » All widgets gone, can’t create new ones

  • Resolved Fraser.Dk

    (@fraserdk)



    After updating to 1.0.2 all our widgets-on-pages went AWOL and in the new top-level Widgets On Pages menu there’s no option to create new widget locations. The settings page is bare.

    Rolling back to 0.12 fixed it. What’s going on?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hey @fraserdk. Sorry to hear your Widgets went missing, they really should not have done.
    In the top level menu the new Widget areas/Sidebars are defined in the Turbo Sidebars item, as in the updated screenshot in the installation guide.

    Could you please let me know what theme and version you’re using? and Perhaps a screenshot of the widgets/sidebars that you have?

    Sorry again for any pain.

    Got it, thanks. It wasn’t obvious that a turbo sidebar was needed to create a widget area.

    Marked as solved.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Oh sorry… I shall make a note for the readme to be more specific.
    Maybe put a link on the existing settings page, too. I had not thought of this.
    I’m also concerned you lost your existing Widgets setup too… so if you’re happy to share the details etc that would be greatly appreciated.

    Hey Todd. As a head’s up, it appears that I also lost all of my homepage widgets with the latest update.. which lead to an unexpected redesign. I also did not realize that I would have to recreate them through the turbo sidebar. For what it’s worth, I would back your recommendation to add a blurb to the ReadMe. I would have waited for a better time to roll the update.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hey @jolisouci… so sorry to hear this. The plan was certainly not for users to have to re-add the Widgets etc. I had thought I had thoroughly tested this but obviously some scenarios have caused issues. In all honesty I had run many different test upgrades (some with named sidebars, some unnamed sidebars, some used in posts/pages and template tags) and believed that I’d covered all scenarios 🙁

    If you wouldn’t mind sharing your theme and version details (including which Widget on Pages version you updated to) that would be great so I can try to dig out what might have gone wrong.

    I’m collating a list of combinations from the last push before I re-release the update. Apologies again.

    Hi,
    all my widgets was gone. Ok, I found them unter inactive and re-add them. But no display on the pages. The integration like [widgets_on_pages id=”Leistungen”] is the same.
    Theme: Elmatheme Dorayaki.

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    Hi @loewenherz

    I think you’re seeing issue that’s described in this thread. Could you please let me know which theme you’re running?

    Oh, I that thread there is a link to a beta version that hopefully has a fix in, if you fancy giving it a try.

    Oh, oh, sorry to hear you’re having issues.

    • This reply was modified 1 year, 3 months ago by  toddhalfpenny.

    Hi Todd,

    Theme is http://www.elmastudio.de/wordpress-themes/dorayaki/ on php7. Do v0.0.12 works with php7? Just replace the new version with this?
    regards
    Loewenherz

    Plugin Author toddhalfpenny

    (@toddhalfpenny)

    @loewenherz, yup v0.0.12 should be PHP7 compliant.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘All widgets gone, can’t create new ones’ is closed to new replies.