Support » Plugins and Hacks » WordPress Popular Posts » "All time" view count not working

  • Hello,

    I believe the “all time” view counter is not working. Since I have updated this plugin with the latest update, it seems to be the only data filter that never changes. The numbers have remained static for weeks despite hundreds of visits to my site. The top post has had its view count at 1,200 some views for weeks straight.

    Any idea what it might be? I run the Stargazer theme.

    Thanks

    https://wordpress.org/plugins/wordpress-popular-posts/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Hector Cabrera

    (@hcabrera)


    Hi there,

    Are you using a caching plugin, by any chance?

    Yes, I use WP supercache.

    Plugin Author Hector Cabrera

    (@hcabrera)


    From the description page:

    Notices
    Starting version 3.0.0, the way plugin tracks views count switched back to AJAX. The reason for this change is to prevent bots / spiders from inflating views count, so if you’re using a caching plugin you should clear its cache after installing / upgrading the WordPress Popular Posts plugin so it can track your posts and pages normally.

    Did you clear WPSC’s cache already? If not, please do so. If you’re using the WPP widget, I’d also advice to enable the Ajaxify feature via Settings > WordPress Popular Posts > Tools before clearing WPSC’s cache.

    My WPSC clears the cache daily. Should I clear the WPP cache too?

    Thanks for the quick response.

    Plugin Author Hector Cabrera

    (@hcabrera)


    Should I clear the WPP cache too?

    Nope, that shouldn’t be necessary.

    If the stats are not being updated, it probably means that WPP’s unable to communicate with your database. And I say probably because without looking at your site I can only guess 😛

    Looks like the AJAX switch did the trick. Thanks!

    Plugin Author Hector Cabrera

    (@hcabrera)


    Don’t mention it, I’m glad to know everything’s OK now.

    I’m marking this topic as resolved, then. Please let me know if you need further help.

    Have a nice day!

    Argh, I hate to say this but it is reverting back to the stats that it originally had recorded.

    When I click on articles on the fly, they update. However, I have left for a few hours and returned, and the articles no longer have the views they had recorded.

    Is the WordPress Super Cache plugin completely incompatible with this perhaps?

    Plugin Author Hector Cabrera

    (@hcabrera)


    Can’t tell for sure, it’s been a very long time since I last tried WP Super Cache.

    Could you please post your site’s URL so I can go take a look?

    Perhaps I should try another caching plugin. The site is alphadark.com. The popular posts are on the right side.

    The top one always reverts back to 1262. The rest follow suit with their counts.

    Plugin Author Hector Cabrera

    (@hcabrera)


    Did you enable the Ajaxify feature? From the code it seems that the feature is either disabled or that WPSC is serving an old version of your sidebar because I can see the regular non-AJAX list there.

    Hey Hector, appreciate your fast response here. AJAX is indeed enabled. I might just try another caching plugin and see what happens. I’ll report back when I know. I think I might go with WP Fastest Cache.

    Plugin Author Hector Cabrera

    (@hcabrera)


    You may also want to report the issue with WPSC’s developer, maybe he could help you figure out what’s happening and you won’t need to switch to another plugin. Let him know that you’re using a sidebar widget which is capable of using AJAX (and that the feature is enabled) but in your sidebar WPSC still lists the non-AJAX version.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘"All time" view count not working’ is closed to new replies.