WordPress.org

Forums

WP Statistics
[resolved] All Search Engine Referrals are "0"? (7 posts)

  1. tianchx
    Member
    Posted 1 year ago #

    why all the "Search Engine Referrals" records are "0"? but i remember "Search Engine Referrals" worked well before updated to ver 4.6. Can ver4.6 work with wordpress 3.6.1? any suggestion?

    http://wordpress.org/plugins/wp-statistics/

  2. Greg Ross
    Member
    Plugin Author

    Posted 1 year ago #

    Bug, fix submitted should be out shortly.

    In the mean time if you need a fix, edit includes/class/statistics.class.php, line 112:

    if( esc_sql(strip_tags($_SERVER['HTTP_REFERER'])) ) {

    should be

    if( !esc_sql(strip_tags($_SERVER['HTTP_REFERER'])) ) {

    Notice the missing ! in front of esc_sql().

  3. tianchx
    Member
    Posted 1 year ago #

    Thank Greg Ross for your solution. i'll modify the code and wait for the results.

  4. tianchx
    Member
    Posted 1 year ago #

    OK! it seems work well!

  5. JenniferEklund
    Member
    Posted 1 year ago #

    Excellent - thanks for posting this! Love this plugin, happy to have ditched Jetpack

  6. Greg Ross
    Member
    Plugin Author

    Posted 1 year ago #

    Now if only they'd pull After the Deadline back out of JetPack it would be great ;)

  7. Greg Ross
    Member
    Plugin Author

    Posted 1 year ago #

    Closing topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Statistics
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.