Forums » Plugin: WP Job Manager » All salaries are now showing USD / YEAR after salary – how to remove?

  • Resolved mattapex

    (@mattapex)


    How can I remove the automatically added default text “USD / YEAR” that’s added after all salary text?

Viewing 15 replies - 1 through 15 (of 15 total)
  • Thread Starter mattapex

    (@mattapex)

    I’ve had to manually edit the wp-job-manager-template.php file to remove the text, which is a complete workaround and obviously only temporary.

    Is there a more permanent fix available? Or do we need to wait for 1.36.3 now?

    Plugin Support Jay

    (@bluejay77)

    Hi @mattapex,

    Thank you for the report. We have added this issue on our issue tracker here:

    https://github.com/Automattic/WP-Job-Manager/issues/2278

    We don’t have an ETA when the fix will be released, I’m afraid. In the meantime, you can use this code snippet as a workaround:

    add_filter( 'wpjm_job_salary_currency', function( $currency ) {
      return 'GBP';
    } );

    You can replace GBP with the currency of your choice.

    I hope that helps! Let us know if you have any other questions.

    Thread Starter mattapex

    (@mattapex)

    Thanks… but the above code would still lead to GBP / YEAR being appended, whereas we have some hourly, daily or monthly pay rates and these will vary from job to job, rather than being consistent across our platform for all jobs.

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    Hi @mattapex,

    the above code would still lead to GBP / YEAR being appended, whereas we have some hourly, daily or monthly pay rates and these will vary from job to job, rather than being consistent across our platform for all jobs.

    This is an improvement that we hope to implement in the next future, as you can read in the GH link below under Improvements: https://github.com/Automattic/WP-Job-Manager/pull/2263

    I reported this thread there so to emphasise this feature request.

    Having the same issue here!!!!

    Salary showing in USD per year as well as GDP https://attenti.co.uk/job/chairbbrc/

    I see this issue was raised 5 DAYS AGO ALEADY.

    Can I just point out that THIS IS AN URGENT ISSUE
    a resolution needs to be found as soon as possible as this is negatively affecting candidates from applying!!!

    Please resolve now.

    Anyone having this issue use this CSS code to remove the duplicate USD field

    however Automattic should find a proper solution to remove this from the plugin.

    li.salary {
    display: none;
    }

    • This reply was modified 1 year, 9 months ago by JMaartenW.
    Plugin Support lastsplash (a11n)

    (@lastsplash)

    Hi @jmaartenw

    We have added your report to the GitHub issue.

    Please follow the issue for updates.

    li.salary {
    display: none;
    }

    makes no difference.

    Plugin Contributor Stef (a11n)

    (@erania-pinnera)

    I can replicate this – the CSS edit can remove the entire field while ideally we want to remove only the currency bit.

    I wasn’t able to find another workaround, so I reported it on the GitHub issue:

    https://github.com/Automattic/WP-Job-Manager/issues/2278#issuecomment-1169761844

    I recommend following it through.

    Hello!
    My workaround:

    CSS:
    div.single_job_listing ul.job-listing-meta.meta li.salary {
    display: none;
    }

    Child-Theme-function:

    //Display "Salary" on the single job page
    	add_action( 'single_job_listing_meta_end', 'display_job_salary_data' );
    	function display_job_salary_data() {
    		global $post;
    
    		$salary = get_post_meta( $post->ID, '_job_salary', true );
    
    		if ( $salary ) {
    		  echo '<li>' . __( 'Bezahlung/Jahr:' ) . ' EUR  ' . esc_html( $salary ) . '</li>';
    		}
    	  }

    Greetings
    Deexperte

    BTW: This issue is an essential draw-back and has to be reprogrammed!

    Plugin Support Mehdi (a11n)

    (@muffinpeace)

    @deexperte Thanks for sharing that workaround.

    After looking closely, our developers found that this is due to the forms being cached, which is expected; however, users should not see that.

    You can find more information on this Github issue:

    https://github.com/Automattic/WP-Job-Manager/pull/2285

    @mattapex

    What is going on with this issue? the github ticket says it’s resolved but it is still happening for me.
    I have to rely on the CSS to remove the duplicate USD Salary field so it only shows the GBP??

    li.salary {
    display: none !important;
    }

    Plugin Support Jay

    (@bluejay77)

    Hi @jmaartenw,

    Can you confirm that you are on the latest version of WP Job Manager? (1.37.0)?

    The changes in the GitHub PR above were released in the current version of WP Job Manager.

    You should be able to configure custom salary settings in WP-admin > Job Listings > Settings. From there, you can Enable Job Salary, and Enable Job Salary Currency Customization. You can specify GBP as the currency instead of USD, as shown in the screencast below.

    https://d.pr/i/n00GgU

    yes I am on version 1.37.0

    i’ve had to hide the USD salary via CSS

    li.salary {
    display: none !important;
    }

    example page https://attenti.co.uk/job/ceobafsa/

    Plugin Author Jake Morrison (a11n)

    (@jakeom)

    Hi @jmaartenw,

    If the job doesn’t have the currency and interval unit set, it would default to what is in settings. You can change the defaults in WP Job Manager’s settings or edit the job listing itself and edit it there.

    Also, if you previously added a salary field using a plugin or code snippet, that might be conflicting with the new built-in implementation.

    Best,

    Jake M.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘All salaries are now showing USD / YEAR after salary – how to remove?’ is closed to new replies.