Support » Plugin: FeedWordPress » all rss feeds show no items

  • dcoder50

    (@dcoder50)



    Every RSS feed I put in fails to show items even a feed from techmeme.com is not working. I am running php 7.0.22

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author C. Johnson

    (@radgeek)

    O.K., weird. Sorry to hear you’re running into this problem. Whatever the cause, it’s probably not directly related to PHP 7, if you are using the most recent version of FeedWordPress (which is currently tested on a PHP 7 server and has incorporated fixes for some compatibility problems that older versions of FWP had).

    Just to make sure I understand, the problem is, that these are feeds you are trying to add (to subscribe to as content sources), using something like the New source: input box under Syndication > Syndicated Sources. You know there’s content on the feeds, but when you add them, it doesn’t show up in FeedWordPress?

    Just to be clear: do you mean that when you first tell FeedWordPress to add the feed, and it goes to the “Feed Finder: Subscribe To…” page, the “Sample Item” panel for that feed indicates that there are no items found on the feed, even before you’ve added it as a source?

    Or do you mean that the “Sample Item” panel shows some content, and you add the feed as a source, but after you add the subscription, no new content comes in to your WordPress posts table?

    dcoder50

    (@dcoder50)

    Yes when first adding a feed and then if I save it. It still shows no items in the feed. Here is an example: https://www.dropbox.com/s/ayo41qeu0skiqiy/Screenshot%202017-10-27%2008.03.50.png?dl=0

    feed: https://www.techmeme.com/feed.xml

    Plugin Author C. Johnson

    (@radgeek)

    O.K., thanks.

    I checked out the URL you provided on my test server (WordPress 4.9 beta, PHP v7.0.22) and didn’t have any trouble finding content:

    https://www.dropbox.com/s/1tlvmox4j4amp5e/Screenshot%20from%202017-10-27%2010-10-41.png?dl=0

    … which would indicate to me that the problem is not in FeedWordPress per se, but in a bad interaction between FeedWordPress and some other feature of your local WordPress installation or hosting environment. The first thing I’d want to look at is, whether or not you are running any add-on modules or other plugins that are intended to work together with FeedWordPress? (For example, I have a number of add-ons that are called things like FWP+: Keyword Filters, FWP+: SIC ‘Em, etc. There are also third-party add-on modules like Bas Schuling’s FeedWordPress Advanced Filters.) If you log in to the WordPress admin interface and go to Plugins > Installed Plugins, do you see any of these listed and activated?

    thatstevensguy

    (@thatstevensguy)

    We recently upgraded our AWS servers. They now run PHP 7.1.11. I am also experiencing this same issue. All feeds are showing as “FeedWordPress found no posts on this feed.”.

    This occurs even when adding fresh feeds to the list.

    thatstevensguy

    (@thatstevensguy)

    We have fixed this issue. SimpleXML is not enabled by default in PHP 7 and must be configured separately.

    However I am still stuck on an old (manually patched) version of this plugin because the current release does not work when I update. Rolling back to our modified 2013.0504 works.

    Plugin Author C. Johnson

    (@radgeek)

    hi @thatstevensguy,

    Glad to hear that you were able to figure out one part of the issue on your end; sorry to hear there is another problem that you’re running into. Could you let me know, either here or (if it’s a long story) via email, (1) what problems you’re seeing with the current version (i.e., what specifically isn’t working) when you update, and (2) what were the patches you applied to 2013.0504?

    Thanks!

    thatstevensguy

    (@thatstevensguy)

    I’ve lost track, but we just patched the strict standards errors as they came up when there was delays in updates to this plugin. It kept working, so we stuck with that build.

    When I install the latest version it simply doesn’t download any posts. Can’t really explain it further than that.

    We do use a couple of hooks to fix Syndication issues (such as duplicates) but I don’t think they are the cause of it not working.

    Plugin Author C. Johnson

    (@radgeek)

    No problem. Would it be possible for you to send me a copy of the patched version (you can get email etc. from here so I can run a diff against 2013.0504 to see if there are any fixes in your version that I have missed in subsequent updates?

    As far as not getting updates in with the newer version: have you tried running an update with some of the Diagnostics on, in particular those having to do with checking each item on the feed, or deciding a post is a new post, duplicate or update? If so, what’d you find? If not, let me know and hopefully I can dash off some step by step for some diagnostic settings that might be useful in troubleshooting this problem.

    dcoder50

    (@dcoder50)

    Just to update, this was my issue as well. After enabling SimpleXML I was able to see the feeds again.

    @dcoder50 Thanks! This solved my problem as well.

    In my case, to solve this issue, I installed the package php7.0-xml using apt-get on Ubuntu 16.04, which includes SimpleXml. So, after restarting my Apache server, my problem was solved.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘all rss feeds show no items’ is closed to new replies.