Support » Plugin: WooCommerce » All products showing as SOLD

  • TwoGunRosie

    (@twogunrosie)


    Apparently I am not the only one with this problem, but I found a fairly quick way to fix it.

    One of two things caused this problem for me: 1) I performed a long overdue WooCommerce database update or 2) I had to remove some variations from almot every single product due to a change in the attributes structure.

    SOLUTION: It turns out that I had to go into each product and simply hit the “Update” button. However, I had 12 pages of products (240 items).

    Here is an easier way: In products list view, I selected all products. I went to “Bulk Actions” and selected “edit.” Under the options for bulk editing, I went to “In stock?” and changed that to “In stock.” I also changed the option for “Sold” to “no.” Then hit the update button. I had to do this for each [age of products, but 12 times was much better than 240 times!

    If you have many more product than I did, you can go to the top of your screen, select “Screen Options” and change the number of products displayed per page (default is 20).

    This doesn’t answer the question about hwy this happens, but it might make it easier for others in similar situations to fix the problem. Hope it helps!

  • The topic ‘All products showing as SOLD’ is closed to new replies.