Support » Plugin: WooCommerce » All products show SALE after woocommerce update

Viewing 15 replies - 1 through 15 (of 15 total)
  • This happened to me as well! I only use woocommerce as a catalog, so nothing is actually for sale at all, making this even more confusing!

    Help -how to remove the “sale” stickers?

    I just posted this, give it a try:

    “Hey guys, thanks for the posts, but I think I may have solved the sales tag issue showing up. Don’t need to code anything, just mess around with options.

    I don’t have prices or add to cart options on my shop, its just a online catalog site, so take that into consideration when trying this method below to rid of sales tag icon over image.
    Here is what to try:
    Go into one of your products that you are selling,
    Products-> click on product you are having sales tag issue with

    -> Scroll down to the Product Data section

    -> If your product data is already on Simple product (note, make sure to remember price of product, as it will clear price under general, if there is no price, don’t worry about it), change to Variable product and update listing (you will see no price when you preview, don’t worry if you want price to show, follow below). Note: the sales tag will be gone when updated using Variable product showing no prices, what I needed for my online catalog, but what if you want price to show? Continue below…

    -> Go back to Product Data and change back to Simple product and add your Regular Price back in and update then preview. Your price will show without the sales tag over image. No need to code to take out sales tag icon, just mess around with the options.

    Very confusing options that Woo has made for this, but this method seems to work, give it a shot, worth a try, as I was pulling my hair out as to why the sales tag would not go away with my no price online catalog.

    Anyways, hope this helps, tried my best to explain with my timeframe:)”

    The topic is under, “Update from 2.0.9 to 2.0.10 Issue”

    Thanks kidace. This worked for me, but I don’t show any prices at all so I left it on variable.
    I tried switching as you said from simple product –> variable –> then back to simple. When set to variable, the sale tag disappeared from the product. Then when set back to a simple product, the Sale tag reappeared.

    Odd. This works for me because I don’t show any prices at all, so I am just switching all my products to variable.

    Is there a way to change all products to variable at once?

    Or, can I revert back to a previous version of Woo?

    I have too many products and don’t want to spend the time to change all of them one at a time!


    @affordablepawn – per the forum guidelines, please start your own thread if you need help. It does not work well to post in other people’s threads.

    Go here and scroll down to create a new thread –

    I have just upgraded from 2.0.9 to 2.0.10 version and experienced the same problem with sales tag on top of the product image. I tried the method @kidace but it didn’t work. Any help is highly appreciated.


    Is it better to roll back to older version? If so, would anyone be so kind to guide me step-by-step to roll back to older version? Thanks.

    @nra54 – it’s better to post your own thread on the WooCommerce sub-forum – so that the developers can help you – see link in my post above.

    Hi – I managed to get rid of the sales stickers by doing these 2 steps…
    1. In my child theme’s functions.php files I added the following:

    remove_action( 'woocommerce_before_shop_loop_item_title', 'woocommerce_show_product_loop_sale_flash', 10 );

    2. In my child theme’s style.css file:

    body.woocommerce span.onsale, body.woocommerce-page span.onsale {
       display: none;
    .woocommerce span.onsale, .woocommerce-page span.onsale {

    That seemed to solve the sales sticker problem. Perhaps not all three lines are necessary – but thought I’d rather cover all bases:)

    Plugin Author James Koster


    This is a known issue and will be fixed in the next update. Keep an eye here;



    go to

    disable following two lines:
    //add_action( ‘woocommerce_before_shop_loop_item_title’, ‘woocommerce_show_product_loop_sale_flash’, 10 );
    //add_action( ‘woocommerce_before_single_product_summary’, ‘woocommerce_show_product_sale_flash’, 10 );

    I am using WordPress 3.7.1.
    and woo commerce 2.0.20 I have disable the following lines see below but i am still getting all my products coming in as a sale item although i only place in a regular price. Any help will be great

    //add_action( ‘woocommerce_before_shop_loop_item_title’, ‘woocommerce_show_product_loop_sale_flash’, 10 );
    //add_action( ‘woocommerce_before_single_product_summary’, ‘woocommerce_show_product_sale_flash’, 10 );

    Can someone tell me how to remove the Recent comment txt in WordPress 3.7.1

    Hi there all,

    I had the same issue with the sales signs. However I tried making the regular price and the sales price the same, which seemed to take the sales signs away.

    Hope it helps someone else.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘All products show SALE after woocommerce update’ is closed to new replies.