Support » How-To and Troubleshooting » All posts show as (no title) after DB restore

All posts show as (no title) after DB restore

  • Taking an existing WP site (created by someone else) and making a local copy for development. After I copy all the files over and import the sql database, all the posts show as “(no title)”, with no time/date/author/tags/etc. Pages are fine.

    The data seems fine in the DB. Problem exists if I import the DB into a clean wordpress filesystem, so it’s probably not any changes made to core on the site. I’ve exported/imported the DB a half dozen different ways to make sure it’s not something weird phpmyadmin is doing.


Viewing 7 replies - 1 through 7 (of 7 total)
  • esmi


    Forum Moderator

    Have you tried switching to the Twenty Eleven theme to rule out any theme-specific problems.

    Yup. Problem exists with a totally clean wordpress install right from the zip with default themes.



    Forum Moderator

    What happens if you empty the db, re-install and then use Tools -> Import/Export to copy the content over into the new install?

    I get hundreds of “failed to import media” notices, it says “all done”, and nothing is imported.

    you ever find a solution to this? I’m having the same problem.

    Never did, unfortunately. Had to abandon the idea of having a local copy for development. Terrified of ever having to migrate hosts.

    I just suffered this same issue and thought I’d lost years of posts , luckily I managed to solve it.

    The original server was running on Ubuntu 13.04 64bit on real hardware , but the server i was moving to was a virtual server running 13.04 32bit.

    I have since spun up a virtual Ubuntu 13.04 64bit server and the mysql import has worked as expected.

    Hope this helps.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘All posts show as (no title) after DB restore’ is closed to new replies.
Skip to toolbar