Support » Fixing WordPress » All posts in Google search Redirected to login

  • All posts in Google search Redirected to login Please suggest me to resolve, I Submit Sitemap to search console again but unable to resolve. as screenshot of google search is https://prnt.sc/lehs1g

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • It seems your login page is been indexed, do you have a redirect set for some pages?
    This page doesn’t redirect to the login: https://loudpages.com/contact-us/

    Thread Starter navdeep5

    (@navdeep5)

    No i haven’t set any redirect

    when you are on a post and you click on “Log in”, it redirects from that post and creates a link like this
    https://loudpages.com/login/?redirect_to=https%3A%2F%2Floudpages.com%2Fseo%2Fseo-optimized-content-writing-loudpages-com%2F”
    These links it creates are been indexed.
    What is the url you have in the”Log In” on the menu?

    Go to the menu and set this “https://loudpages.com/login/” as the URL for the log in, if you can’t change it, delete the “Log In” menu item, and add a custom link, with “https://loudpages.com/login/” as the URL and set the name as “Log In”.
    This should fix your problem, you then will have to go remove these pages from your Google Search Console so they don’t come up when people search for your site.

    Moderator bcworkz

    (@bcworkz)

    You should add rel="nofollow" to your log in links, as well as disallow that page in robots.txt. Then as Femi suggests, remove the login links through Google search console.

    Your last reply, a link to a page about writing for better SEO and nothing else, is dangerously close to causing you to be considered a spammer. It appears to be off topic, so I am removing it from public view. If it is on topic, you may re-post along with an explanation on why it pertains to your topic. If you do not want to be treated as a spammer, don’t post links to you own site without explanation 🙂 TIA for your understanding.

    Thread Starter navdeep5

    (@navdeep5)

    Thanks to all, I change login settings

    It resolves

    But how do i remove these links from Google search console, should i resubmit sitemap

    Yes, resubmit your sitemap. On Search Console, there is an option to remove URLs, you have to copy – paste the wrong URLs that has been indexed by Google, and request they should be removed.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘All posts in Google search Redirected to login’ is closed to new replies.