Support » Fixing WordPress » All Post Are Not Exporting

  • I am hosting at Bluehost. I keep an updated mirror copy of my blog on a local host on my computer. As such, I export my stuff from the online Dashboard each month and import it to my local host. Until this month, I have had no problem. But this month I am not getting all my post. I’ve exported and re-imported the file several times over the past four days. The size of the file is 4.96MB, and I’ve changed my import size on my local host to 10MB in my .ini file.

    The latest 17 post on my online blog are not exporting. I am stuck at exporting 625 post and 45 pages. The pages are correct, but I should have 642 posts. I’ve opened the xml file and did a search for those posts, but they are not there. I have all the latest WordPress updates. I’ve searched this forum and the knowledge base at Bluehost and found no help. Does anyone have any ideas why all the post are not exporting?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Why not backup the SQL database instead?

    For backup purposes only, I do. In fact, I backup everything once a month, not just SQL. However, I like to export my post and pages and import them into my local host for several reason, one being ease of editing out things no longer needed or applicable. It also serves as a tool for playing around with different themes and theme design.

    Any idea why all post are not exporting?

    I’d guess that even though you changed your php.ini settings, there’s a lower limit and you’re hitting it. I’d check with BlueHost about it.

    Thanks Ipstenu. I’ll go to Bluehost help desk and see what they can offer.

    OK, I found the problem. I’m surprised that someone didn’t respond more quickly to this. After a lot more digging, I found this entry in the WordPress forum that is a year old. In my earlier search for “export problem”, this didn’t pop up because of the title. The title on this one addresses “Fatal error” instead of export. I missed it because I wasn’t getting the “Fatal error” when I exported so I didn’t include that in my search on the forum.

    At any rate, the fix is to go into the WP-Settings.php and reset “define(‘WP_MEMORY_LIMIT’, ‘32M’)” to “define(‘WP_MEMORY_LIMIT’, ‘64M’)”.

    The previous string in the forum link talks about some additional things that could be tried if this doesn’t work, but this worked for me.

    That would make a lot of sense 🙂

    As for why no one else made the connection … You weren’t getting an error message, which means it’s a hit-or-miss at guessing why it borks.


    I have the same problem. However, despite changing the memory limit in wp-settings, I still misses some posts in the export file.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘All Post Are Not Exporting’ is closed to new replies.