WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] All Post and Page content missing, titles show

[Resolved] All Post and Page content missing, titles show

  • Hi,
    I checked my website today and found that all my pages and posts are missing, though the titles are still there, and they are in the correct categories, etc. The Pages and Posts do not show in the Admin area, either, though the post/page count at the top is there. I have removed the .htaccess file and re saved the permalinks in the Settings area, but this has not helped. I reinstalled the latest WordPress install and restored yesterday’s database, too. but still the same.
    Any ideas on how to troubleshoot this would be greatly appreciated!
    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hey man!

    You got a site to check out this issue?

    Also have you looked into the database to see if the copy is there?

    Site URL?

    the site is hbama.com

    I did a restore from the database backup up through several weeks ago. Not sure when the problem started, but I did update the MySQL and PHP to the new versions to be able to move from WordPress 2.x to the latest version 3.3, a few weeks back, but did not notice the issue until someone pointed it out (I don’t go to the site myself that often)

    Can you login to your site?

    I can, but at the moment I am deleting it and reuploading it from my local copy to see if something has been corrupted. I can log in and see users, but not Pages or Posts, thought the page and post count (in published, trash, spam, etc.) shows correctly. I cannot add a test page or post, though, so there seems to be something with the base installation gone wrong.

    Can you try these steps?

    1. Deactivate all the plugins
    2. Delete inactive plugins
    3. Revert to Twenty Eleven theme

    And see if there is any change and if errors are still persisting?

    It seems all your posts and other contents are intact. So, make sure that you have a complete backup of your site before you start the above steps. If nothing works, you will have to reinstall WordPress.

    Also, it seems that the problems arose because you upgraded to WordPress 3.4.1 from a very old version, without trying extended upgrade.

    I think that I have tracked it down to the Event Calendar plugin. Thanks for your input on this. I will have to come up with a better Event Calendar for this site.
    Thanks again,
    Rich

    If the problem is fixed, please mark the topic as resolved.

    Now that I have looked closer, there is a plugin called Event Calendar 3 for PHP 5, which appears to be a version of Event Calendar 3 that is required for later PHP. The original one did not indicate that it wouldn’t work or that an upgrade/new version was needed.

    Anyway, glad to note that you could solve the problem.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] All Post and Page content missing, titles show’ is closed to new replies.
Skip to toolbar