WordPress.org

Support

Support » Your WordPress » All permalinks point to home page

All permalinks point to home page

  • When ever I click on a permaling it just directs people back to the home page.
    Has anybody experienced anything like this before?
    Any advice would be much appreciated.

Viewing 11 replies - 1 through 11 (of 11 total)
  • URL ?

    I find that happens with themes without a 404 page as part of the template, when you server kicks back a 404 it loads the homepage. That just from personal experience.

    What is your permalinks structure? Not giving details and not giving a link it is difficult to expect any solution…

    Yeah, sorry. Here is a URL :

    http://benward.dyndns.org/wordpress

    I’m using the default permalink structure with the blix theme.

    I’m positive they were working when I first installed WordPress. But I didn’t keep checking them so I’m not sure when they stopped working.

    Strange. The links on the sidebar (and menu) seem to work ok… Made any changes to The Loop?

    I have only edited the sidebar to incluce a couple of plugins. And I changed the banner at the top of the page. As far as I can remember that’s it.

    Your links seem to work fine here!

    The links at the top of each post just reload the home page. I’m not talking about the links on the sidebar. Sorry I should have made that clear.

    I’m having a same problem, but different circumstances. I’m migrating from a personal server to a paid one. Links worked fine on the personal one but now all permalinks direct to the home page. Can’t seem to find anything wrong with the htaccess file.

    I’m migrating from: http://martz.blogdns.org:8081/
    and to http://blog.mattmartz.com/

    I’m using this as my permalink structure (for both):
    /archive/%year%/%monthnum%/%day%/%postname%/

    and this is what’s in the htaccess file for the blog.mattmartz.com subdomain:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php
    </IfModule>

    # END WordPress

    I’m running a VERY heavily modified (and incomplete) K2 theme under wordpress 2.0

    I did notice that when I added a page to the site, some lines were added above the htaccess code, but when i updated the permalink structure they disappeared again.

    I’ve been trying to figure this out all day, thanks for any help.

    ~M

    edit: the links that don’t work are pages (at the top), clicking the titles of the posts, using the previous navigation (there is no next cause it’s on the front page), and the rss links at the bottom… and that’s all there’s really access to. I have a feeling it’s either the theme (which was working before) or a plugin is screwing something up.

    solution:

    I originally had an older version of wordpress on my paid for server, and wp-blog-header.php in the root folder was at fault (or at least, it was the only file i noticed had a significant file size change between versions). anyways it works now, hope this helps someone else

    I’m having the same problem as the original poster.

    URL: GarnishBar.com

    Structure: /%year%/%monthnum%/%day%/%postname%/

    Any help is appreciated.

    Look at the other thread you just bumped. No need to bump ’em all.

    http://wordpress.org/support/topic/75643?replies=3

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘All permalinks point to home page’ is closed to new replies.