Viewing 15 replies - 1 through 15 (of 18 total)
  • Thread Starter AlexBrtn

    (@alexbrtn)

    Settings: one and two
    htaccess Really Simple SSL

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @alexbrtn I see this in your .htaccess:
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/ [R=301,L]

    It should be this:
    RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]

    I just tested this in our plugin, the $1 is added without problems, so not sure how it’s gone missing! But if you either disable, then enable the redirect again, or add it manually, the problem should be resolved.

    Thread Starter AlexBrtn

    (@alexbrtn)

    @rogierlankhorst
    Disabled plugin and reactivated. Unfortunately it happened again. no $1

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Strange, can’t reproduce that behaviour. Possibly there’s a conflict with another plugin happening here.

    If you remove the plugin comments above and below the lines, add the $1, then the plugin stops rewriting it. That should resolve your issue.

    alternatively you can completely disable the .htaccess redirect, and change to php redirect.

    Thread Starter AlexBrtn

    (@alexbrtn)

    Disabled the plugin again (refused https) and got a 500 error.
    Changing the address to http in wp_options doesn’t help. Site not working

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    I just discovered an issue which occurs on deactivating the plugin. Please check in the wpconfig file if you have the string ‘cookie settings’ at the top. This is possibly not removed on deactivation. That should restore the site.

    Then you can add the $1 to the .htaccess.

    Thread Starter AlexBrtn

    (@alexbrtn)

    <?php
     cookie settings

    there is. Delete along with <?php ?

    • This reply was modified 1 year, 6 months ago by AlexBrtn.
    Thread Starter AlexBrtn

    (@alexbrtn)

    <?php not delete)
    Work! Thnx

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    Only cookie settings.

    I’ve also reproduced your issue with the .htaccess redirect. It looks like it’s a combination with a hardening feature. For now I would recommend to disable the .htaccess redirect until I’ve released the fix for this.

    Thread Starter AlexBrtn

    (@alexbrtn)

    Reinstalled plugin. Activated. Added $1 but still links from http://www go to the home page.
    The problem remained the same. Yes.
    Thank you, I’ll disable the redirect

    Thread Starter AlexBrtn

    (@alexbrtn)

    Interesting. I completely deactivated and removed the plugin, switched to http (without www) but I still have a redirect to the main page with httpS
    Example http://www.merge.com.ua/odnokomnatnaya-kvartira-v-zvezdnom-gorodke-odessa/

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    I have a fix ready for this .htaccess issue which you can try:

    https://github.com/Really-Simple-Plugins/really-simple-ssl

    We’re doing some extra tests, and will release an update later this evening.

    Thread Starter AlexBrtn

    (@alexbrtn)

    Reinstalled plugin. Activated. Work on php redirect. v 6.0.3 (downloaded from wordpress)

    Same issue here. I fixed it the way @alexbrtn did. (reinstall v6.0.3 with php redirect).

    Waiting for the new update.

    Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    @lichking @alexbrtn we have just released 6.0.4, which fixes this problem. Thanks for reporting, and working with us to resolve the issue!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘All pages redirect to the main domain from http://www to https://’ is closed to new replies.