WordPress.org

Forums

[resolved] All Pages Redirect To Front Page (4 posts)

  1. Zix
    Member
    Posted 2 years ago #

    Relevant Settings:

    1. Static page set to Home Page under Settings --> Reading
    2. Permalink set to Custom Structure with a value of /%postname%

    Symptoms:

    Home Page launches correctly, but when I click on any other link I'm redirected back to static Front Page.
    If I manually copy/paste url of a page into the browser, I'm redirected to Home page. (For instance - http://squarepegtech.net/sound-like-you).

    URL: http://squarepegtech.net

    I have seen other posts on this, mostly having to do with .htaccess, but none of them seem to have solutions.

    What I have tried:

    1. Reset Custom Structure to other values.
    2. Deleted .htaccess and allowed it to be recreated.
    3. Experimented with various permissions for the .htaccess file (666, 660, etc).
    4. Cursing under my breath and out loud.

    None of these have worked.

    I'm sure someone has solved this in the past, but I can't seem to find documentation. Can anyone offer suggestions or point me to documentation?

    Mucho appreciation!

  2. kjodle
    Member
    Posted 2 years ago #

    You need to have two pages for your static home page, and neither of these can be your home page.

    Create a page that you wish to use for a static home page. Edit this carefully, as this will be what people see when they first visit your website.

    Create a second page for your blog posts. You do not need to edit this page.

    http://codex.wordpress.org/Creating_a_Static_Front_Page

  3. Zix
    Member
    Posted 2 years ago #

    Thanks kjodle.

    I was able to figure out the problem a little while ago. It was related to a Plugin I had installed about 2 years ago but had not used in a long time.

    I went through and disabled Plugins one at a time until I found the culprit. I then blew that one up with high explosives. :)

    All working correctly now!

  4. kjodle
    Member
    Posted 2 years ago #

    Ah, the old "stealth plugin" problem! Glad you got it fixed!

Topic Closed

This topic has been closed to new replies.

About this Topic