Support » Plugin: Yoast SEO » All pages noindex nightmare

  • Resolved cl0ne

    (@cl0ne)



    Hello everyone.

    Pardon the dramatic title. I having this mind-numbing problem. All of my pages, be default, are being filed as “noindex”, and not the other way around. I went above and beyond and enabled “index” on every post type and taxonomy for Yoast (which was the case mostly). I have no idea what’s causing this issue. There’s no mention of “robots” in .htaccess and have done nothing apart from manually disabling indexing on individual pages and on sitemap. That is about the most I have done with Yoast’s configuration. The problem came to my attention when I submitted the sitemap and I was getting this error on the console: “Url blocked by robots.txt.”.

    The sitemap has its default configuration:
    User-agent: *
    Disallow: /wp-admin/
    Allow: /wp-admin/admin-ajax.php

    It could be a plugin conflict but I’m not sure if a conflict can render such results, though I suppose anything is possible.

    Your help is appreciated!

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi,

    Upon checking the page source of the URL you provided, it looks like there’s a meta robot tag that is outputting the noindex and follow tags. However, it isn’t inside the Yoast SEO header plugin data, so it doesn’t look like this is caused by the Yoast SEO plugin. Can you please set the posts/pages to index and see if that fixes the issue?

    Otherwise, that sounds like a plugin or theme conflict. Can you try and gather as much information for us as possible? Please perform the following:

    1. Make sure the issue doesn’t persist when Yoast SEO is disabled.
    2. Check for conflicts.
    3. Check for JavaScript errors with your console.

    If you find any JavaScript errors related to Yoast SEO or if there is a conflict with a plugin or a theme, you can create a new GitHub issue for our developers. Please report the issue to a third party developer as well.

    If you didn’t find any conflicts or errors, we think the issue is specific to your site. We’d need to investigate further but are unable to do so on these forums. You can purchase Yoast SEO Premium and receive our Premium email support and we can help you further.

    cl0ne

    (@cl0ne)

    Thank you for the fast response.

    I have found the plugin that is causing the meta. I’m very upset because this is the core plugin needed for my implementation.

    I’m going to create a Github issue.

    Plugin Support Michael Tina

    (@mikes41720)

    Hello,

    Please feel free to log a GitHub issue at the relevant repository and reference this thread if needed.

    Setting this as resolved.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘All pages noindex nightmare’ is closed to new replies.