Support » Plugin: Insert Pages » All pages lose post content when plugin is enabled

  • Resolved messanoir

    (@messanoir)


    HI, first off I want to say I love the plugin, and I am hoping this can be figured out as it would make my site building so much easier and faster.

    The issue I have, is that when the plugin is active, and I am viewing pages of the site (when not logged into WP backend) all of the info that would be in the body of a post is missing. The title of the page and the post show, just not the content. I did all the standard testing, using different themes, including the standard twenty-seventeen, and disabling all other plugins, even using different browsers, and having my hosting provider double check the server, and verify the issue happened when the checked it from their location. I tried removing the plugin completely and re-adding it, even tried on a fresh install of WP with a new database.

    That’s what made this weird, if it was such a general issue that required so little to happen, why wasn’t it happening all over, it had to be something with how I was using it or had it setup, right? I just couldn’t figure it out. I’ll admit at first I didn’t even know the issue was this plugin, to be honest, I didn’t know what ones could be causing it. I did a lot of googling and going through a lot of wordpress forums looking for a similar issue, and what kept coming up was people talking about something regarding jquery conflicts (which as a new person to all this I didn’t understand) and in more layman’s terms, something regarding plugins that added themselves to the TinyMCE editor in wordpress somehow causing the content to disappear. I thought, well, I guess I can check that, though I only have two that do anything with the editor. Yours and one for allowing you to collapse/hide sections of text in a post. I disabled both, and sure enough the issue went away and everything was fine. After doing the standard trial and error testing I found if the Insert Pages was disabled, all my content came back.

    Im still not sure why this happens, or what could be different in my setup to make it happen, but I wanted to let you know and maybe we can get it figured out? I have used a workaround for now, but would much rather use your plugin as it’s far less complicated to maintain. Thanks for letting me get this all out, and if you need any more info, please let me know.

Viewing 1 replies (of 1 total)
  • Plugin Author Paul Ryan

    (@figureone)

    Hm, I’ve never seen that before. I would guess it’s something specific about your setup, but without details it’s hard to say for sure.

    Can you try changing Settings > Insert Pages > Insert method and see if that does anything?

    Also try looking at your web server error logs and see if there’s anything relevant in there. Also your browser javascript console.

Viewing 1 replies (of 1 total)
  • The topic ‘All pages lose post content when plugin is enabled’ is closed to new replies.