Support » Plugin: WP Hide & Security Enhancer » All of sudden all re-write rules have a period in front?

  • I had a few re-write rules set in the plugin that were working perfectly till recently, I am not sure what happened? I’ll give you an example:

    New Includes Path
    Previously: include
    Now: .include

    New Content Path
    Previously: content
    Now: .content

    While the above changes are fine, the admin slug is now broken!

    New Admin Url
    Previously: backend
    Now: .backend (404’s when loading)

    What did I break and how do I fix it? Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author nsp-code

    (@nsp-code)

    Hi,
    You mean you included . (period) in front of slugs?

    Thanks

    Plugin Author nsp-code

    (@nsp-code)

    Sorry, just saw the topic title..
    Can you check with wph_settings option within wp_options table and see if the fields also include the period?

    Yes, here is how the fields look:
    “new_content_path”;s:8:”.content”
    “new_include_path”;s:8:”.include”

    Again I do not desire the periods, it just started happening. Can’t trace it to a plugin either, this is with everything disabled! And if I try to change it within phpMyAdmin it just resets all settings to this:
    a:4:{s:15:"module_settings";a:0:{}s:13:"recovery_code";s:32:"49445319e0a2d970b101b5784d75c35f";s:7:"version";s:5:"1.3.5";s:18:"write_check_string";s:16:"1474780204_17723";}

    Here is my settings in it’s entirety:
    a:4:{s:15:"module_settings";a:46:{s:14:"new_theme_path";s:0:"";s:19:"new_style_file_path";s:0:"";s:16:"style_file_clean";s:3:"yes";s:20:"new_theme_child_path";s:0:"";s:21:"child_style_file_path";s:0:"";s:22:"child_style_file_clean";s:3:"yes";s:16:"new_content_path";s:8:".content";s:21:"block_wp_content_path";s:2:"no";s:16:"new_xml_rpc_path";s:0:"";s:13:"block_xml_rpc";s:2:"no";s:20:"disable_xml_rpc_auth";s:2:"no";s:18:"remove_xml_rpc_tag";s:3:"yes";s:20:"new_wp_comments_post";s:0:"";s:26:"block_wp_comments_post_url";s:2:"no";s:17:"block_license_txt";s:3:"yes";s:17:"block_readme_html";s:3:"yes";s:21:"block_wp_activate_php";s:2:"no";s:17:"block_wp_cron_php";s:2:"no";s:27:"block_default_wp_signup_php";s:2:"no";s:20:"block_other_wp_files";s:2:"no";s:21:"remove_generator_meta";s:3:"yes";s:18:"remove_wlwmanifest";s:3:"yes";s:17:"remove_feed_links";s:3:"yes";s:29:"disable_json_rest_wphead_link";s:3:"yes";s:15:"remove_rsd_link";s:3:"yes";s:25:"remove_adjacent_posts_rel";s:3:"yes";s:14:"remove_profile";s:3:"yes";s:16:"remove_canonical";s:3:"yes";s:16:"disable_wpemojia";s:3:"yes";s:24:"disable_tinymce_wpemojia";s:3:"yes";s:21:"styles_remove_version";s:3:"yes";s:26:"styles_remove_id_attribute";s:3:"yes";s:22:"scripts_remove_version";s:3:"yes";s:19:"remove_x_powered_by";s:3:"yes";s:17:"remove_x_pingback";s:3:"yes";s:20:"remove_html_comments";s:3:"yes";s:18:"clean_body_classes";s:3:"yes";s:19:"clean_menu_items_id";s:3:"yes";s:24:"clean_menu_items_classes";s:3:"yes";s:18:"clean_post_classes";s:3:"yes";s:19:"clean_image_classes";s:3:"yes";s:16:"new_include_path";s:8:".include";s:19:"block_wpinclude_url";s:2:"no";s:16:"new_wp_login_php";s:0:"";s:9:"admin_url";s:0:"";s:23:"block_default_admin_url";s:2:"no";}s:13:"recovery_code";s:32:"268c43d138b94223cd96f3246f6b7343";s:7:"version";s:5:"1.3.5";s:18:"write_check_string";s:16:"1474682863_54206";}

    Plugin Author nsp-code

    (@nsp-code)

    I’am not sure what’s happen, there’s no reason for this to change automatically. so there must be something else, either a manual change or possible another code which interfered with the settings.
    Can you set those again as need then let’s see what happen, if occur again we’ll have to check deeper.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘All of sudden all re-write rules have a period in front?’ is closed to new replies.