Support » Plugin: Contact Form 7 » All of my forms stopped working.

  • Resolved hotpotato888

    (@hotpotato888)


    Heya,

    I have three forms on my website:

    https://radassyogi.com/yogis-request/
    https://radassyogi.com/contact/
    https://radassyogi.com/private-lessons/

    A few days ago, I changed my website URL and my email address. As you can imagine, I had to update A LOT of stuff on my site that broke in the process. My three forms were among the wreckage. I deleted my forms, deactivated Contact Form 7, and uninstalled the plugin. Then I reinstalled the plugin and re-built my three forms (linked above).

    … they all worked just fine, or I thought so, anyway. I tested all three forms, and the emails sent successfully. That was last night. Tonight, none of the forms works. I double-checked my ReCaptcha keys. I deleted/uninstalled/recreated my forms … and they still won’t work.

    I copied and pasted the working code (they worked before I changed my URL, email address and, consequentially, my ReCaptcha code … new gmail, new Google account, new ReCaptcha keys).

    I’m not sure where to look. I get the yellow error and the message that asks you to wait and try again, later.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Thank you, ReCaptcha was the issue! I didn’t realize the forms would work without the ReCaptcha integration set up. I’ll look into some other options for spam.

    CF7 5.1.+ updated to reCAPTCHA v3.

    The orange/yellow error border indicates reCAPTCHA v3 is not working correctly on your site.

    You may see this error if you’ve:

    • previously used reCAPTCHA v2 with CF7
    • updated to CF7 5.1.1 or newer and
    • not changed your previous reCAPTCHA v2 keys to reCAPTCHA v3 keys at Contact > Integration.

    Hey @buzztone, thanks for the note.

    I was using reCAPTCHA V3 with CF7 5.1.1 with the correct (v3) reCAPTCHA keys. Still a no go.

    The strange part is, it worked immediately after I uninstalled/reinstalled … but went back to the validation error (which I noticed the following day).

    • This reply was modified 6 months, 2 weeks ago by hotpotato888.

    If you’ve registered correctly for reCAPTCHA v3 (by following the instructions at reCAPTCHA v3) & it’s working, you should now see the reCAPTCHA Privacy badge displayed at the bottom of every page on your site (not just the pages where you’ve got CF7 forms).

    recaptchaV3-privacy-icon.png

    If the reCAPTCHA badge is not showing, this shows that reCAPTCHA v3 is not working on your site.

    when I had reCAPTCHA installed, I had the badges, @buzztone

    The resolution to this issue is to use another product.

    Update: I completely uninstalled reCAPTCHA and deleted my website from the console screen over at Google reCAPTCHA. Then I added my site, fresh, which created new site keys. Then I re-installed reCAPTCHA, and now it seems to be working.

    Update – A few hours later, and I’m getting the validation errors, again, on all of my forms. I don’t understand why reCAPTCHA works for a bit, and then stops.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘All of my forms stopped working.’ is closed to new replies.