WordPress.org

Forums

WordPress SEO by Yoast
[resolved] All new versions from 1.4.25 don't work correctly (6 posts)

  1. arniarni
    Member
    Posted 1 year ago #

    Hi,

    I can not update this plugin from 1.4.25 to any new version because after updation I can not edit any page - in previous version I get a blank page and in last 1.5.2.5 version I get error message in file class-wpseo-options.php. Page editor is unavailable.
    Is anybody who solved this problem?

    https://wordpress.org/plugins/wordpress-seo/

  2. jrf
    Member
    Posted 1 year ago #

    What error messages are you getting ? And does this still happen if you switch to one of the WP standard themes ?

  3. arniarni
    Member
    Posted 1 year ago #

    Fatal error: Call to undefined function ctype_digit() in /home/domain/domain.com/docs/wp-content/plugins/wordpress-seo/inc/class-wpseo-options.php on line 720

    I tried to change theme to standard but get a same error.

  4. jrf
    Member
    Posted 1 year ago #

    Oh dear, your webhosts has actively disabled a standard PHP extension called ctype. Please ask them to re-enable it.

  5. jrf
    Member
    Posted 1 year ago #

    FYI: As more people might be having this issue, I've send in a work-around for this anyway which will most likely be included in the next release. Even so, a host disabling ctype is not a good thing.

  6. arniarni
    Member
    Posted 1 year ago #

    Hi jrf,
    Thank you very mach! After enabling of ctype function script works good.
    Problem was solved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress SEO by Yoast
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic