WordPress.org

Forums

[resolved] All my wordpress sites stopped working all of a sudden (8 posts)

  1. sipboy
    Member
    Posted 6 years ago #

    My main site at tommiepowers.com is now showing this:

    Parse error: syntax error, unexpected T_IF, expecting ',' or ';' in /home1/socialco/public_html/tommiepowers/index.php on line 18

    At first it said this:

    Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ',' or ';' in /home1/socialco/public_html/tommiepowers/index.php on line 18

    and then I upgraded the site to 2.8 and it worked fine for a day or so.

    All of my wordpress sites are doing this and I can't figure out why.

    Can someone help me with this?

  2. esmi
    Forum Moderator
    Posted 6 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems.

    - renaming the plugins folder via FTP

    - reading http://wordpress.org/support/topic/279132

  3. sipboy
    Member
    Posted 6 years ago #

    Yeah, I did all that before upgrading to 2.8 and nothing seemed to work. Then after the upgrade, the site worked fine for a day or so and then it happened again now I have tried the same process again except I can't update anymore.

    All my wordpress sites have the very same issue and I have different themes, pligins, etc. on all of them.

    What else could this be?

    Have I been hacked?

  4. esmi
    Forum Moderator
    Posted 6 years ago #

    Some plugin incompatibilities don't seem to kick in for a few days (the longest I've seen took about a week). So deactivate all of the plugins again - ideally using the FTP method as the odd "inactive" plugin can continue to cause problems.

  5. iridiax
    Member
    Posted 6 years ago #

    Have I been hacked?

    Hacking is a good possibility. Have you looked in these index files for suspicious code?

  6. ouch
    Member
    Posted 6 years ago #

    I am getting the same error on multiple sites hosted at dreamhost and one at hostgator.

    Parse error: syntax error, unexpected T_IF, expecting ',' or ';' in /home/

    They were working fine, and this started.

  7. esmi
    Forum Moderator
    Posted 6 years ago #

    Please don't hijack topics. Start your own if you need help.

  8. sipboy
    Member
    Posted 6 years ago #

    Thanks everyone!

    I found out that I have been hacked and I found suspicious code in all my index.php files.

    I went in an remove all the bad code.

    The bastards also left behind a script somewhere on my account that keeping putting code on my sites.

    I still have to rid my account of the script because until then, this will continue to occur every so often.

    Anybody reading this, start taking measures now to add some security to your wordpress sites.

    If you have not been hacked before, eventually it will happen.

Topic Closed

This topic has been closed to new replies.

About this Topic