Support » Plugin: Leaflet Map » All maps are gone

  • GevoelVoorHumus

    (@gevoelvoorhumus)


    I have tons of maps on my site, and since the 3.0.0 update, they are all gray areas.

    Edit: I reverted to 2.23.3 and all is well.

Viewing 15 replies - 16 through 30 (of 37 total)
  • Plugin Author bozdoz

    (@bozdoz)

    What geocoder are you using?

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    OpenStreetMap Nominatim.

    Plugin Author bozdoz

    (@bozdoz)

    V3.0.1 hopefully fixes this issue if you are keen to try it out. There is a possibility that the commas are being added after it’s validated, but I’m hoping that won’t happen. 95% sure it will work. 🙂

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    Alas! I’ll leave it 3.0.1, so can see the errors.

    gyldensaa

    (@gyldensaa)

    Hi GevoelVoorHumus

    I also have issues with Leaflet Map version 3.x.
    You mentioned in the thread that you downgraded to version 2.x.
    How did you get your hands on version 2.x – from a backup or from bozdoz?
    Can you point me to a link to the latest Leaflet Map 2.x?

    Kind regards

    Thomas Christensen@gyldensaa

    • This reply was modified 5 months ago by gyldensaa.
    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    Hi @gyldensaa, I use the plugin on multiple sites. So I could download a copy from another site.

    hupe13

    (@hupe13)

    You can download old versions from here:
    https://wordpress.org/plugins/leaflet-map/advanced/
    at the bottom.

    But please say what issues you have.

    @gevoelvoorhumus:
    Do you need emojis? It seems, the problems are in interaction with these.
    I have installed the plugin https://wordpress.org/plugins/speed-up-clean-wp/
    to disable emojis.

    P.S. There must be something else. I disabled the plugin on my test site and tested your code, it works.

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    @hupe13 No, I don’t need them. Thanks for the tip, but it does not work for me…

    hupe13

    (@hupe13)

    See my P.S. The post have crossed.

    Plugin Author bozdoz

    (@bozdoz)

    I’m not at a computer for a few days. Any chance someone could capture a screenshot or a copy paste of the problem js? The error itself probably isn’t helpful, but to see if the lat lng still have commas would be helpful.

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    Hi @bozdoz, is this what you need? This is 3.0.1.

    Uncaught TypeError: t is null
        project Projection.SphericalMercator.js:24
        latLngToPoint CRS.js:28
        project Map.js:993
        _getNewPixelOrigin Map.js:1493
        _move Map.js:1235
        _resetView Map.js:1197
        setView Map.js:206
        <anonymous> (index):120
        init construct-leaflet-map.js:44
    Plugin Author bozdoz

    (@bozdoz)

    Not really but looks like it’s happening at ‘setView’ which makes me believe it’s still adding commas to the coordinates. But actually would be helpful to see if it’s adding commas or removing the lat/lng altogether. Either one is possible but suggest different solutions.

    If you’re in the developer tools you need to open up the first script tag under the map. Then near the bottom of the script tag is the call to ‘setView’.

    Thanks for all the help on this! Definitely fixable! The main problem is that I don’t know how to reproduce the issue!

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    I could not copy the code, so I made a screenshot. Hope it helps!

    hupe13

    (@hupe13)

    That’s strange. My locale is german, there is also a comma instead of a period in the decimal number. I don’t have this problem. Following shortcode runs successfully on one page, in english as well as in german:

    [leaflet-map fitbounds]
    [leaflet-marker lat=44,67 lng=-63,61 title="test"]Test[/leaflet-marker]
    [leaflet-map fitbounds]
    [leaflet-marker lat=44.67 lng=-63.61 title="test"]Test[/leaflet-marker]
    [leaflet-map zoom=11 address="Liessel,Noord-Brabant, Nederland"] [leaflet-marker message="Liessel" visible]

    My next idea: Clear the geocoder cache.

    Plugin Author bozdoz

    (@bozdoz)

    Yep it’s the comma. Thanks. That screenshot helps a lot! I can fix that. Won’t be able to get that done for a few days as I’m on vacation.

Viewing 15 replies - 16 through 30 (of 37 total)
  • You must be logged in to reply to this topic.