Support » Plugin: Leaflet Map » All maps are gone

Viewing 15 replies - 1 through 15 (of 37 total)
  • Plugin Author bozdoz

    (@bozdoz)

    Are there any custom settings that you’re using? Thanks for the heads up.

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    I all looks pretty standard to me. Do you want me to reset the settings?

    Plugin Author bozdoz

    (@bozdoz)

    Not necessarily. Might be a shortcode that’s breaking it. Do you have any short codes that I could test? Any complicated ones? For this update I was required to sanitize many fields for the shortcodes and settings. All of it seemed backwards compatible, but there might be some edge cases I missed

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    I figured it might be a compatibility problem, so I tested [leaflet-map] in a shortcode-block. Didn’t work in 3.0.0.

    I tested [leaflet-map zoom=11 address=”Liessel,Noord-Brabant, Nederland”]
    [leaflet-marker message=”Liessel” visible] in 2.23.3, it worked. I upgrade to 3.0.0, it stopped working.

    I tried it on two websites.

    Plugin Author bozdoz

    (@bozdoz)

    Nothing jumps out at me. I’ll give it a test anyway. Thanks!

    Are you using a caching plugin?

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    @hupe13 On one site, yes. On the other, no.

    Plugin Author bozdoz

    (@bozdoz)

    I’d love to check out the javascript errors if you have a chance to try out v3 again. Just tried your shortcode and simulated an upgrade, without issue. So I’m not sure what the issue could be.

    • This reply was modified 6 months, 3 weeks ago by bozdoz. Reason: typo
    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    2.23.3 displays this:
    Uncaught SyntaxError: missing name after . operator

    
    3.0.0. (on the same) page displays this:
    Uncaught TypeError: t is null (leaflet.js:5:24399)
    project [unpkg site redacted]/leaflet@1.4.0/dist/leaflet.js:5
    latLngToPoint [unpkg site redacted]/leaflet@1.4.0/dist/leaflet.js:5
    project [unpkg site redacted]/leaflet@1.4.0/dist/leaflet.js:5
    _getNewPixelOrigin [unpkg site redacted]/leaflet@1.4.0/dist/leaflet.js:5
    _move [unpkg site redacted]/leaflet@1.4.0/dist/leaflet.js:5
    _resetView [unpkg site redacted]/leaflet@1.4.0/dist/leaflet.js:5
    setView [unpkg site redacted]/leaflet@1.4.0/dist/leaflet.js:5
    <anonymous> [my redacted site]/plaats/liessel/:147
    init [my redacted site]/wp-content/plugins/leaflet-map/scripts/construct-leaflet-map.js?ver=3.0.0:44
    (Async: EventListener.handleEvent)
    <anonymous> [my redacted site]/wp-content/plugins/leaflet-map/scripts/construct-leaflet-map.js?ver=3.0.0:377
    <anonymous> [my redacted site]/wp-content/plugins/leaflet-map/scripts/construct-leaflet-map.js?ver=3.0.0:381
    
    • This reply was modified 6 months, 3 weeks ago by Yui. Reason: formatting
    Plugin Author bozdoz

    (@bozdoz)

    Right. Looks like there is a problem there somewhere, even in the v2 one. Could I see the site just to try to figure out why the syntax error is happening on v2?

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    Plugin Author bozdoz

    (@bozdoz)

    that’s v3, and I see the issue with that. It’s formatting numbers with commas instead of decimals. I imagine that’s a locale-specific thing. I will investigate and push a fix for that today. As for the v2 issue, no clues from that.

    Thread Starter GevoelVoorHumus

    (@gevoelvoorhumus)

    Sorry, I downgraded to v2 for you. Check the link again!

    Plugin Author bozdoz

    (@bozdoz)

    Thanks! That appears to be an issue with wpemoji:

    t.src=e,t.defer=t.,

    They have t., and no property. So I’ll just fix that locale specific number formatter problem

Viewing 15 replies - 1 through 15 (of 37 total)
  • The topic ‘All maps are gone’ is closed to new replies.