Support » Plugin: Simple Basic Contact Form » All mail end up in my Spam folder

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi @suanlian

    Something in the email contents (subject or content) is getting flagged by your email server and the email gets put in the spam folder.

    If you have access to the control panel (for the hosting) there should be a section about emails in there which will show all incoming emails and their status, for the ones that got spammed there should be additional information on what triggered them to get spammed.

    If you’re not sure where to find that the best approach is to contact the hosting provider (unless the email service you use is external) and ask them to check what triggers it to go to spam.

    Alternative is to make a filter (again, in the email service settings, not the plugin) so that emails that come from the form (for example filter based on email subject) do not get sent to spam.

    Thread Starter Suanlian Tangpua

    (@suanlian)

    Hi,

    Thank you for the quick reply. I have added gmail and yohoo to the spam safelist in rackspace. It is perfectly working as of now… Even though they don’t recommend to add gmail, yahoo etc on the safelist as it could result in spam arriving in the inbox.

    Thanks again. Your plugin is very simple and feather weight.

    Plugin Author WPKube

    (@wpkube)

    Hi @suanlian

    You’re welcome, happy to hear it’s sorted out.

    If there’s an option in the filters to filter by email address you could add the email address from the “From Address” option in WP admin > Settings > Contact Form.

    All the emails from the form get sent out by that address with the “reply to” parameter set to the actual email of the person who contacted you, so no need to allow or gmail and yahoo emails.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘All mail end up in my Spam folder’ is closed to new replies.