WordPress.org

Forums

All Links have Localhost (5 posts)

  1. tymierb
    Member
    Posted 6 years ago #

    I have wordpress set up in a Virtual Machine for testing and development, and I am having a huge problem. I work with a team of two other guys who all need to gain access to the wordpress site. WordPress is set up and working perfectly on the local machine where the server software is installed, but when you navigate to the site from another computer nothing looks as it should. The server will serve the site but it is unstyled. After some digging, I found that all of the links have "localhost" causing the browser to try to serve the page itself, instead of pulling it from the actual server. I want to know why all of my links include "localhost". Did I do something wrong during the setup process? Please advise.

    `!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr" lang="en-US">

    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

    <title> Biomed Development</title>

    <link rel="stylesheet" href="http://localhost/wordpress/wp-content/themes/default/style.css" type="text/css" media="screen" />
    <link rel="pingback" href="http://localhost/wordpress/xmlrpc.php" />

    <style type="text/css" media="screen">

    #page { background: url("http://localhost/wordpress/wp-content/themes/default/images/kubrickbg-ltr.jpg") repeat-y top; border: none; }

    </style>

    <meta name='robots' content='noindex,nofollow' />

    <link rel="alternate" type="application/rss+xml" title="Biomed Development » Feed" href="http://localhost/wordpress/?feed=rss2" />
    <link rel="alternate" type="application/rss+xml" title="Biomed Development » Comments Feed" href="http://localhost/wordpress/?feed=comments-rss2" />
    <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://localhost/wordpress/xmlrpc.php?rsd" />
    <link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://localhost/wordpress/wp-includes/wlwmanifest.xml" />
    <link rel='index' title='Biomed Development' href='http://localhost/wordpress' />
    <meta name="generator" content="WordPress 2.8.1" />
    </head>
    <body class="home blog">
    <div id="page">

    <div id="header" role="banner">
    <div id="headerimg">
    <h1>Biomed Development</h1>

    <div class="description">Just another WordPress weblog</div>
    </div>
    </div>
    <hr />

  2. esmi
    Forum Moderator
    Posted 6 years ago #

    What url did you use in Admin/Settings/General?

  3. tymierb
    Member
    Posted 6 years ago #

    localhost....that'd explain it. how do i change it?

  4. esmi
    Forum Moderator
    Posted 6 years ago #

    If you have an IP address on your local network, try using that.

  5. poparosa
    Member
    Posted 5 years ago #

    Thank you esmi and tymierb for the pointers to the fix for the only issue I had in the WordPress installation.

    It took more than the advertised five minutes to deploy on an instance of Amazon EC2, maybe because I was generating a work instruction (or a map of my travels - take your pick). This was the only issue I had and you folks nailed it, along with the way to fix it.

    I love the collaboration available on the web.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.